Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

cPanel & WHM update failure

Discussion in 'General Discussion' started by brendym, Nov 11, 2015.

  1. brendym

    brendym Registered

    Joined:
    Oct 28, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    England
    cPanel Access Level:
    Root Administrator
    Hi over the last few days I regularly get an update failure notice.

    "Sysup: Needed system RPMs were not installed: db4-devel"

    But in the log it states "Package db4-devel-4.7.25-20.el6_7.x86_64 is obsoleted by db53-devel-5.3.21-1ice.el6.x86_64 which is already installed"

    Any ideas how to solve? Many thanks :)

    Here's my log file:

    Code:
    ----------------------------------------------------------------------------------------------------
    => Log opened from cPanel Update (upcp) - Slave (24185) at Thu Nov 12 01:26:46 2015
    [2015-11-12 01:26:46 +0000]   Detected cron=0 (SSH connection detected)
    [2015-11-12 01:26:46 +0000]   1% complete
    [2015-11-12 01:26:46 +0000]   Running Standardized hooks
    [2015-11-12 01:26:47 +0000]   2% complete
    [2015-11-12 01:26:47 +0000]   mtime on upcp is 1444768298 (Tue Oct 13 21:31:38 2015)
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow (24187) at Thu Nov 12 01:26:49 2015
    [2015-11-12 01:26:49 +0000]   Detected version '11.52.0.21' from version file.
    [2015-11-12 01:26:49 +0000]   Running version '11.52.0.21' of updatenow.
    [2015-11-12 01:26:49 +0000]   Using mirror '52.28.145.234' for host 'httpupdate.cpanel.net'.
    [2015-11-12 01:26:49 +0000]   Successfully verified signature for cpanel (key types: release).
    [2015-11-12 01:26:49 +0000]   Target version set to '11.52.0.22'
    [2015-11-12 01:26:49 +0000]   Switching to 11.52.0.22 to determine if we can reach that version without failure.
    [2015-11-12 01:26:50 +0000]   Retrieving and staging /cpanelsync/11.52.0.22/cpanel/scripts/updatenow.static.bz2
    [2015-11-12 01:26:50 +0000]   Using mirror '52.28.145.234' for host 'httpupdate.cpanel.net'.
    [2015-11-12 01:26:51 +0000]   Successfully verified signature for cpanel (key types: release).
    [2015-11-12 01:26:51 +0000]   Set permissions on /usr/local/cpanel/scripts/updatenow.static-cpanelsync to 0700
    [2015-11-12 01:26:51 +0000]   Become an updatenow.static for version: 11.52.0.22
    => Log closed Thu Nov 12 01:26:51 2015
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow.static-cpanelsync (24187) at Thu Nov 12 01:26:51 2015
    [2015-11-12 01:26:51 +0000]   Detected version '11.52.0.21' from version file.
    [2015-11-12 01:26:51 +0000]   Running version '11.52.0.22' of updatenow.
    [2015-11-12 01:26:51 +0000]   Using mirror '52.28.145.234' for host 'httpupdate.cpanel.net'.
    [2015-11-12 01:26:51 +0000]   Successfully verified signature for cpanel (key types: release).
    [2015-11-12 01:26:51 +0000]   Target version set to '11.52.0.22'
    [2015-11-12 01:26:51 +0000]   Checking license
    [2015-11-12 01:26:53 +0000]   License file check complete
    [2015-11-12 01:26:53 +0000]   Checking that the RPM DB is OK...
    [2015-11-12 01:26:53 +0000]   glibc-2.12-1.166.el6_7.3.x86_64
    [2015-11-12 01:26:53 +0000]   OK: RPM DB is responding to queries
    [2015-11-12 01:26:53 +0000]   Testing if rpm_is_working RPM is installed
    [2015-11-12 01:26:53 +0000]   package rpm_is_working is not installed
    [2015-11-12 01:26:53 +0000]   Testing if it's possible to install a simple RPM
    [2015-11-12 01:26:54 +0000]   Preparing...                ##################################################
    [2015-11-12 01:26:54 +0000]   rpm_is_working              ##################################################
    [2015-11-12 01:26:55 +0000]   Switching to version '11.52.0.22' of updatenow to perform sync.
    [2015-11-12 01:26:55 +0000]   checkyum version 22.3
    [2015-11-12 01:27:17 +0000]   checkyum version 22.3
    [2015-11-12 01:27:20 +0000]   Loaded plugins: fastestmirror
    [2015-11-12 01:27:20 +0000]   Setting up Install Process
    [2015-11-12 01:27:20 +0000]   Loading mirror speeds from cached hostfile
    [2015-11-12 01:27:21 +0000]    * base: mirror.vorboss.net
    [2015-11-12 01:27:21 +0000]    * epel: mirror.bytemark.co.uk
    [2015-11-12 01:27:21 +0000]    * extras: mirror.vorboss.net
    [2015-11-12 01:27:21 +0000]    * updates: mirrors.coreix.net
    [2015-11-12 01:27:24 +0000]   Package db4-devel-4.7.25-20.el6_7.x86_64 is obsoleted by db53-devel-5.3.21-1ice.el6.x86_64 which is already installed
    [2015-11-12 01:27:24 +0000]   Nothing to do
    [2015-11-12 01:27:24 +0000]   Prelinking shared libraries and binaries: /usr/sbin/prelink -av -mR
    [2015-11-12 01:27:56 +0000]   checkyum version 22.3
    [2015-11-12 01:27:58 +0000] E Sysup: Needed system RPMs were not installed: db4-devel
    [2015-11-12 01:27:58 +0000] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
    [2015-11-12 01:27:58 +0000]   The Administrator will be notified to review this output when this script completes
    => Log closed Thu Nov 12 01:27:58 2015
    [2015-11-12 01:27:58 +0000]   17% complete
    [2015-11-12 01:27:58 +0000] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1447291606.log` failed, exited with code 18 (signal = 0)
    => Log closed Thu Nov 12 01:28:01 2015
    
    
     
    #1 brendym, Nov 11, 2015
    Last edited by a moderator: Nov 12, 2015
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,961
    Likes Received:
    1,821
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    That looks like an issue with your OS that you should be able to reproduce with the following command:

    Code:
    yum update
    You may need to remove certain YUM repos, or consult with your provider about which packages are safe to remove.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. brendym

    brendym Registered

    Joined:
    Oct 28, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    England
    cPanel Access Level:
    Root Administrator
    Hi there, yum update completes fine with no errors or issues...

    All packages are up to date.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,961
    Likes Received:
    1,821
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Could you verify if the cPanel update still fails when running the "/scripts/upcp" command?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. brendym

    brendym Registered

    Joined:
    Oct 28, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    England
    cPanel Access Level:
    Root Administrator
    Hi yes, the log file above is from running the command /scripts/upcp, also tried /scripts/upcp -force
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,961
    Likes Received:
    1,821
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. brendym

    brendym Registered

    Joined:
    Oct 28, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    England
    cPanel Access Level:
    Root Administrator
    Ticket: 7383163
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,961
    Likes Received:
    1,821
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    To update, this issue was addressed after removing a custom YUM repo.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice