The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel & WHM Version 11.30 Long-Term Support Announcement

Discussion in 'cPanel Announcements' started by cPanelDavidG, Feb 28, 2011.

  1. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    cPanel & WHM version 11.30 will be a Long-Term Support version of our software.

    A Long-Term Support version of cPanel & WHM has the following attributes:


    • We will apply critical security fixes to this major version throughout its lifespan (at least 18 months).
    • Feature updates will be limited to changes that improve compatibility with later versions.
    The Long-Term Support aspect of version 11.30 will be important to users whose servers run operating systems affected by our new End of Life Policy.

    Supported Operating Systems

    Beginning with cPanel & WHM version 11.30, cPanel, Inc. will enact an End of Life Policy for operating systems.

    Linux systems older than CentOS 4, or RedHat® Enterprise Linux® 4, may upgrade to cPanel & WHM 11.30, but not beyond. cPanel will not provide licenses for new installations of any Linux system that has reached end of life, as defined by the new policy.

    All FreeBSD® systems will continue to use cPanel & WHM 11.30, until we release a new version officially supporting FreeBSD. We will license new installations of cPanel & WHM 11.30 on versions of FreeBSD that we have designated as supported in the 11.30 system requirements.

    Operating Systems Affected

    The following operating systems are considered legacy systems. They will not be licensed for cPanel & WHM versions later than 11.30. (This is not an exhaustive list.)

    Operating System - Version(s)

    CentOS 3

    Debian® 3

    Fedora® All versions

    FreeBSD All versions

    Mandrake/Mandriva All versions

    openSUSE 11

    RedHat Legacy 7.3, 9

    RedHat Enterprise Linux 2.1, 3

    SUSE All versions

    In summary, cPanel & WHM will not update to a version newer than 11.30 if the server operating system is not one of the following:

    • CentOS 4+
    • RHEL 4+

    cPanel & WHM 11.30 Lifespan

    cPanel & WHM 11.30 begins our efforts to fully decouple cPanel & WHM from the operating system. Decoupling is the process of isolating the core of cPanel & WHM from the areas of cPanel & WHM that manage, and interact with, the operating system. Decoupling will allow us to separate the operating system's requirements from the core of cPanel & WHM. As a result, we will be able to integrate our software with the OS more effectively and efficiently.

    We expect this process to provide the following long-term benefits:

    • It will allow us to deploy product updates in a more rapid and focused manner.
    • Conflicts between operating systems and cPanel & WHM will be minimized.
    • It will allow us to simplify our quality testing process, which, in turn, will improve software installations and updates.
    • Data centers will be able to plan operating system support customizations and gain greater control over deployments.
    Once cPanel & WHM is fully decoupled from the operating system, cPanel & WHM 11.30 will reach the end of its lifespan. At that time we will evaluate re-introducing support for FreeBSD and other operating systems.

    Click here to read more...
     
    #1 cPanelDavidG, Feb 28, 2011
    Last edited: Feb 28, 2011
Loading...

Share This Page