The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

“cpanellogd.lock” is not a valid service name.

Discussion in 'General Discussion' started by esaesa, Nov 24, 2014.

  1. esaesa

    esaesa Member

    Joined:
    Mar 6, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    I got “cpanellogd.lock” is not a valid service name. during saving service manager configuration.

    I was enabling Eximstats then i got the following log after saving
    Code:
    Saving Changes to exim-26 (disabled)......Done
    
    Saving Changes to clamd (enabled) using default driver......Done
    
    Saving Changes to cpanellogd.lock (enabled) using custom (/etc/chkserv.d/cpanellogd.lock) driver......Done
    
    Saving Changes to cpdavd (enabled) using default driver......Done
    
    Saving Changes to crond (enabled) using default driver......Done
    
    Saving Changes to dnsadmin (enabled) using default driver......Done
    
    Saving Changes to entropychat (disabled)......Done
    
    Saving Changes to exim (enabled) using default driver......Done
    
    Saving Changes to ftpd (enabled) using default driver......Done
    
    Saving Changes to httpd (enabled) using default driver......Done
    
    Saving Changes to imap (enabled) using default driver......Done
    
    Saving Changes to ipaliases (enabled) using default driver......Done
    
    Saving Changes to lfd (enabled) using custom (/etc/chkserv.d/lfd) driver......Done
    
    Saving Changes to mailman (enabled) using default driver......Done
    
    Saving Changes to mysql (enabled) using default driver......Done
    
    Saving Changes to named (enabled) using default driver......Done
    
    Saving Changes to rsyslogd (enabled) using default driver......Done
    
    Saving Changes to spamd (enabled) using default driver......Done
    
    Saving Changes to sshd (enabled) using default driver......Done
    
    Saving Changes to tailwatchd (enabled)......Done
    
    “cpanellogd.lock” is not a valid service name.
     at /usr/local/cpanel/Cpanel/Exception.pm line 102.
    	Cpanel::Exception::new("Cpanel::Exception::InvalidParameter", "\x{e2}\x{80}\x{9c}[_1]\x{e2}\x{80}\x{9d} is not a valid service name.", ARRAY(0x9d82a58)) called at /usr/local/cpanel/Cpanel/Exception.pm line 53
    	Cpanel::Exception::create("InvalidParameter", "\x{e2}\x{80}\x{9c}[_1]\x{e2}\x{80}\x{9d} is not a valid service name.", ARRAY(0x9d82a58)) called at /usr/local/cpanel/scripts/restartsrv line 395
    	Scripts::restartsrv::_lookup_service_restart_info(Scripts::restartsrv=HASH(0x9d7b5b4), "cpanellogd.lock") called at /usr/local/cpanel/scripts/restartsrv line 42
    	Scripts::restartsrv::script("Scripts::restartsrv", "--wait", "cpanellogd.lock") called at /usr/local/cpanel/scripts/restartsrv line 21
    Waiting for “exim” to restart ……………waiting for “exim” to initialize …………………………………finished.
    
    Connection Test:
         Successfully connected to 127.0.0.1:25 and received response: “220”.
    
    Startup Log:
         Starting clamd: [  OK  ]
         Starting exim: [  OK  ]
         0 processes (antirelayd) sent signal 9
         /usr/local/cpanel/scripts/update_sa_rules: running in background
    
    Log Messages:
         2014-11-24 17:26:31 exim 4.84 daemon started: pid=18561, -q1h, listening for SMTP on port 25 (IPv6 and IPv4) port 587 (IPv6 and IPv4) and for SMTPS on port 465 (IPv6 and IPv4)
         2014-11-24 17:26:16 exim 4.84 daemon started: pid=18477, -q1h, listening for SMTP on port 25 (IPv6 and IPv4) port 587 (IPv6 and IPv4) and for SMTPS on port 465 (IPv6 and IPv4)
    
    exim started successfully.
    Waiting for “tailwatchd” to restart ……………………waiting for “tailwatchd” to initialize ……………finished.
    
    Service Status:
         tailwatchd (tailwatchd) running as root with PID 18629 (pidfile check method)
    
    Startup Log:
         [Mon Nov 24 17:26:35 2014] Starting /usr/local/cpanel/libexec/tailwatch/tailwatchd daemon
         Log is at /usr/local/cpanel/logs/tailwatchd_log
    
    tailwatchd started successfully.
    
    Service Changes Complete
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please check to see if that file exists in the location referenced:

    /etc/chkserv.d/cpanellogd.lock

    If so, please remove that file and let us know if the issue persists.

    Thank you.
     

Share This Page