Cpanel's exim a security hole according to nessusd

BianchiDude

Well-Known Member
PartnerNOC
Jul 2, 2005
617
0
166
I ran a scan on my cpanel server with nessusd and its saying exim is a security hole:
results|com|mydomain.com|smtp (25/tcp)|11852|Security Hole|\nSynopsis :\n\nAn open SMTP relay is running on this port.\n\nDescription :\n\nThe remote SMTP server is insufficiently protected against relaying. \nThis means that it allows spammers to use your mail server to send \ntheir mails to the world, thus wasting your network bandwidth.\n\nSolution :\n\nReconfigure your SMTP server so that it cannot be used as a relay \nany more.\n\nRisk factor :\n\nHigh / CVSS Base Score : 7.8\n(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)\n\nPlugin output :\n\nNessus was able to relay mails by sending those sequences :\n\n MAIL FROM: <[email protected]>\n RCPT TO: <nobody%[email protected]>\n\n

How can I fix this?

TIA
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
I ran a scan on my cpanel server with nessusd and its saying exim is a security hole:
results|com|mydomain.com|smtp (25/tcp)|11852|Security Hole|\nSynopsis :\n\nAn open SMTP relay is running on this port.\n\nDescription :\n\nThe remote SMTP server is insufficiently protected against relaying. \nThis means that it allows spammers to use your mail server to send \ntheir mails to the world, thus wasting your network bandwidth.\n\nSolution :\n\nReconfigure your SMTP server so that it cannot be used as a relay \nany more.\n\nRisk factor :\n\nHigh / CVSS Base Score : 7.8\n(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)\n\nPlugin output :\n\nNessus was able to relay mails by sending those sequences :\n\n MAIL FROM: <[email protected]>\n RCPT TO: <nobody%[email protected]>\n\n

How can I fix this?

TIA
cPanel/WHM does not set up an open relay. However, POP before SMTP authentication will trigger scanners into thinking you have an open relay. POP before SMTP authentication is enabled by default and allows anyone who has successfully authenticated via POP3 within the past 30 minutes to send outbound mail via your server.

This is different from an open relay where server authentication is not required at all.

If you want to force SMTP authentication for all outbound mail (effectively disabling POP before SMTP authentication), go to WHM -> Service Configuration -> Service Manager and uncheck "Antirelayd" (under TailwatchD). Then click "save" at the bottom of the page.