The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpbackup/daily is 0.00 days old and backup does not start! help!

Discussion in 'Data Protection' started by pikuser5, Apr 11, 2012.

  1. pikuser5

    pikuser5 Member

    Joined:
    Mar 3, 2010
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    hi!
    today i have this small problem... :p

    [cpbackup] backup point /backup/cpbackup/daily is 0.00 days old
    [cpbackup] The following backups were already up to date: daily

    and the backup does not start!...

    What can i do?

    WHM 11.32.2 (build 15)
    CENTOS 5.8 i686 standard

    Thanks to all guys!
    you are great!
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    If its already run for today and you wanted to run it again you can do so via command line with this command:
    /scripts/cpbackup --force
     
  3. pikuser5

    pikuser5 Member

    Joined:
    Mar 3, 2010
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    ok with this command the backup is started correctly.

    but for five consecutive night i read in the logs:
    [cpbackup] backup point /backup/cpbackup/daily is 0.00 days old
    [cpbackup] The following backups were already up to date: daily

    and the backups were not performed... :eek:
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You might try going back over all your Backup settings and re-save them. Not sure if that's helpful but can't hurt to try.

    If you suspect some sort of defect here, I suggest you put in a ticket to cPanel Support so they can get a closer look to confirm or not. Backups are very important. If there's a problem here, cPanel needs to know about it to fix it.

    I'm not seeing this on any of my servers and they all backup every night of the week.
     
  5. tonedog

    tonedog Member

    Joined:
    Nov 11, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I am having the same issue. The backup settings look to be in order. It started a few weeks ago.

    Anyone have a solution?

    Thanks.
     
  6. websmith

    websmith Member

    Joined:
    Jun 3, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Same trouble here, just noticed I had no backups since mar.29, cpbackup seems to have failed after I upgraded to 11.32. (it was about the same time, anyway)

    Re-saving my cpanel backup settings seems to have set things straight. Maybe the cron was not set correctly or something...
     
    #6 websmith, Apr 22, 2012
    Last edited: Apr 22, 2012
  7. websmith

    websmith Member

    Joined:
    Jun 3, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Spoke too soon. Not fixed.

    [cpbackup] Started at Mon Apr 23 01:00:01 2012
    [cpbackup] Setting I/O priority to reduce system load: best-effort: prio 3
    [cpbackup] Starting full MySQL database backups
    /bin/gtar: Removing leading `/' from member names
    /bin/gtar: /var/lib/mysql/mysql.sock: socket ignored
    [cpbackup] backup point /backup/cpbackup/daily is 0.00 days old
    [cpbackup] The following backups were already up to date: daily
    [cpbackup] Executing user defined post backup script (/usr/local/cpanel/scripts/postcpbackup).
    Backup Rotate: Successfully moved daily/ backup to Monday_20120423/
    CleanBackups Plug-in: Detected this script was executed by /scripts/cpbackup
    CleanBackups Plug-in: auto clean is DISABLED, aborting...
    [cpbackup] Completed at Mon Apr 23 01:00:29 2012
     
  8. tonedog

    tonedog Member

    Joined:
    Nov 11, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I've found the problem. It seems to be that CPanel backup now assumes that a missing "daily" directory = backup is completed whereas before it wasn't. The backup rotation script we are using (by configserver) does a "mv" on the daily directory and therefore the directory is no longer present at the end. I tested this by simply making a new "daily" directory and copying in "cpbackupstatus.cfg" from today's directory and the backup ran just fine.

    I've asked configserver to post the final solution to their script here for us all.
     
  9. tonedog

    tonedog Member

    Joined:
    Nov 11, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I should also mention or request that CPanel fix this because if any other circumstance causes the "daily" directory to be removed we still need/want the backup to run.
     
  10. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    If you feel there may be some sort of defect here, its best to report it into the system:
    http://go.cpanel.net/bugs


    Thanks in advance,
     
  11. tonedog

    tonedog Member

    Joined:
    Nov 11, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    :) In the time it took you to post that you could have posted the bug report. And yes, don't you agree that it is some sort of defect? If the "daily" directory does not exist the system cannot possibly assume the backup is up to date. There is no evidence that it is. ;)
     
  12. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You're the one with the affected server. cPanel will need to login to your server for a closer look.

    I'm using the same scripts as you are, I'm not having this issue as I previously mentioned in this thread. I didn't delete a directory and attempt to duplicate this either though.
     
  13. tonedog

    tonedog Member

    Joined:
    Nov 11, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Hmm, so does your daily directory not get removed each day by the rotate script and are you on WHM 11.32.2 (build 18)? Oh and btw, I did post a ticket. :)

    Thanks!
     
  14. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    11.32.2 Build 23 (CURRENT) here.

    I receive no messages such as this one:
    [cpbackup] backup point /backup/cpbackup/daily is 0.00 days old

    Thanks for posting the ticket. Whatever is going on, the right people are on the case, I'm sure. :)
     
  15. swampy

    swampy Well-Known Member

    Joined:
    Jan 30, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    0
    I too am having the same issue and i am using the backup rotation script by configserver

    please any one with a fix.

    Thanks
     
  16. tonedog

    tonedog Member

    Joined:
    Nov 11, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Sorry, I thought they were going to post it here. Attached is the new dowbackup.pl file they sent me. You are going to need to copy this to file to /usr/bin/ (*note I had to add a ".txt" to the end of it to get the forum to attach it. Remove the ".txt" so it is named only "dowbackup.pl")

    Also! After you add this file you must do one of these two things:

    Run the backup with the --force option
    OR
    Recreate your /backup/cpbackup/daily/ directory and copy in one of your recent "cpbackupstatus.cfg" files (you can find this in one of your recent dated backup folders or even your weekly or monthly folders).

    You will only need to do this once as either one of these things will leave you a good "daily" directory going forward and the new dowbackup.pl script will no longer leave you without one.

    -TD

    P.S. I thought I would also mention that CPanel support said this was fixed on an upcoming release... but regardless this new
     

    Attached Files:

  17. swampy

    swampy Well-Known Member

    Joined:
    Jan 30, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the update.
     
  18. papal

    papal Registered

    Joined:
    Jun 8, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hey everyone!
    On my friend's website she seems to have the same problem.. no backups since February. The log file for daily backup says:

    [cpbackup] backup point /backup/cpbackup/daily is 0.99 days old
    [cpbackup] backup point /backup/cpbackup/weekly is 1.99 days old

    But I can't seem to find a backup/cpbackup folder. Sorry for the dumb question, but where on cpanel do i run a script to force a backup??
     
Loading...

Share This Page