The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpbackup hangs on first account

Discussion in 'Data Protection' started by dev.null, Apr 15, 2010.

  1. dev.null

    dev.null Well-Known Member

    Joined:
    May 27, 2003
    Messages:
    75
    Likes Received:
    1
    Trophy Points:
    6
    I checked in on my backup logs, and log after log looks just like this:
    Code:
    root@vhost3 [/usr/local/cpanel/logs/cpbackup]# cat 1270554383.log 
    [cpbackup] Started at Tue Apr  6 06:46:23 2010
    [cpbackup] Running account backup with target : /mnt/BACKUP/cpbackup/daily
    pkgacct started.
    pkgacct version 8.3 - user : melissa - archive version: 3 - running with uid 0
    Copying Reseller Config...Done
    Copying Suspension Info (if needed)...Done
    Copying SSL Certificates, CSRS, and Keys...Done
    Copying Domain Keys....Done
    Copying Counter Data....Done
    Copying Bandwidth Data.......the180letters.com...Done
    Copying Dns Zones.......the180letters.com...Done
    Copying Mail files....Done
    Copying frontpage files....Done
    Copying proftpd file....Done
    Copy userdata............
    Copy custom virtualhost templates............
    Done
    Leaving timeout safety mode
    Copying mailman lists....Done
    Copying mailman archives....Done
    Copying homedir....
    
    If I run cpbackup by hand and tail the log indicated, it ends the exact same way, and I let it go for hours before I finally get tired of looking at it.

    I've gone and killed all cpbackup processes and all child processes of them and tried it again. Same result.

    Any ideas on why it just hangs on copying homedir?
     
  2. kuldeep_

    kuldeep_ Well-Known Member

    Joined:
    Apr 24, 2010
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Check if you have enough disk space available for generating backup.
     
  3. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    That's simple --- the backup is getting redirected to "dev.null" *JOKE* :rolleyes:

    On a more serious note ....

    Check the space on your backup partition / drive as you will need a minimum of TWICE the space as the amount of data that you are backing up for processing and compression and such.

    (So if your total data to backup is 10 GB the you need 20 GB for the backup storage space.)

    The other thing I would look at closely is the size of the logs from the account that never finishes. Are those logs unusually large in size?

    How much data is stored on this account?

    If it is over 2 GB, it's likely going to begin having problems backing up and beyond a certain size point would fail and hang just like you described in your post above.

    Also you might want to look at the ownership of the files in that account because backup typically doesn't pickup files and folders that are owned by the user "nobody" so make sure everything is owned by the owner.

    Another area to look at is your firewall settings and more specifically the secondary support programs BFD and LFD (go with APF and CSF respectively) which if mis-configured may be killing your backup process

    While on the topic of "killing a process", how much system memory does your server have? You will need a sufficient amount of memory on the server to handle the backup processing.

    If you are on a normal VPS, well nevermind --- you might be having other issues to worry about anyway. ;)
     
  4. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Please check the cPanel error log for possible clues; the cPanel error log can be found at the following path:
    Code:
    /usr/local/cpanel/logs/error_log
    To monitor for new error log details I recommend using the following command (via root SSH access) immediately before initiating the cPanel backup ("cpbackup") process:
    Code:
    # tail -fvn0 /usr/local/cpanel/logs/error_log
     
    #4 cPanelDon, Apr 27, 2010
    Last edited: Apr 27, 2010
Loading...

Share This Page