The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpbackup not working corectly

Discussion in 'Data Protection' started by merlinpa1969, Jul 7, 2007.

  1. merlinpa1969

    merlinpa1969 Well-Known Member

    Joined:
    Dec 3, 2003
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    PA
    cPanel Access Level:
    Root Administrator
    Hello,

    all of our boxes are running the release version of cpanel/whm

    and since june 26th none of our backups seem to work,
    IF I manually run /scripts/cpbackup it works but dosnt seem to work with the crons,

    can someone please help here.
     
  2. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    A couple thoughts... are you sure it's not working, or are you just not getting the email report? Are you getting emails about any of your other cron tasks? Are you doing anything that might be modifying things in your /backups/cpbackup/daily backup dir? I've noticed that some modifications in there can make the backup script think it has already been run that day.
     
  3. merlinpa1969

    merlinpa1969 Well-Known Member

    Joined:
    Dec 3, 2003
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    PA
    cPanel Access Level:
    Root Administrator
    I have manually went and verified that the files are not updated,
    we are doing nothing in these files,
    and its happening on more than one server,

    its ODD,
    I will manualy run them every night for the time being
     
  4. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    Is it possible that the following scenario is happening...

    * cpbackup fails one night for some unknown reason, so the next day you run it manually through shell
    * that next night, cpbackup doesn't run because it detects that it's already run that day (the manual one you did)
    * the following morning you don't get the backup report, so you run it manually again, causing it not to run automatically that night also
    * and so on

    In other words, if I were to run cpbackup manually every night at 10:00, it will never run by cron in the early morn.

    I may be overstating the obvious, but thought it might help. I hope someone can help you out.
     
  5. merlinpa1969

    merlinpa1969 Well-Known Member

    Joined:
    Dec 3, 2003
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    PA
    cPanel Access Level:
    Root Administrator
    I appreciate the input, however until I started manualy running them after midnight
    no backups had been run since the last time I ran them on the 26th of June,

    and whats weird, is that I have to use that if I dont manually run the backups I get up in the morning and rusn /scripts/backup it says that its current but none of the files or folders ( dates modified ) have changed and I know that I have made changes to my test files.
     
Loading...

Share This Page