The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpbackup returning tar errors

Discussion in 'Data Protection' started by NightStorm, Dec 4, 2005.

  1. NightStorm

    NightStorm Well-Known Member

    Joined:
    Jul 28, 2003
    Messages:
    286
    Likes Received:
    4
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    Since the last update (the one that also caused the problems with mod_security) I have been receiving this error during the nightly backups. If I was to remove this script, then force a cpanel update, would it automatically replace the script with one that works? I haven't changed the file in any way, so I can only assume that the one it grabbed from the update was messed up somewhere.
    Has anyone else experienced this error, and know of a quickie fix for it? I'm wary of messing with this file, and don't want to wreck things more than they are now.
     
  2. SubZero

    SubZero Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    100
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Balmumcu, Istanbul, TR
    same here...
    I have fixed modsec error via changing its password in the phpmyadmin. you can cat the script tht is giving error and copy paste the new password :)
     
  3. NightStorm

    NightStorm Well-Known Member

    Joined:
    Jul 28, 2003
    Messages:
    286
    Likes Received:
    4
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    I fixed the mod_sec problem 15 minutes after it started... but the backup problem is ongoing.
     
  4. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Yep, I'm getting this too. Any ideas from anyone would be appreciated.

    This started on the 3rd of December after upgrading to 10.8.1-CURRENT_41 from 10.8.1-CURRENT_30-something. CentOS 3.6.
     
  5. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    I got it on Fedora 4 -so it is an error. They updated the cpbackup script on that day..
     
  6. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    Edit /scripts/cpbackup and check around line 345, there is the tar command. The format for it was as follows;

    Code:
    cpusystem("tar","cfzp","$target/dirs/$rawdir.tar.gz","$dir");
    
    In the lastest one they are trying to use --exclude=path and it is not structured correctly.

    They have listed -

    Code:
    cpusystem('tar',"--exclude='*/proc'",'cfzp',"$target/dirs/$rawdir.tar.gz",$dir);
    
    When it should be
    Code:
    cpusystem('tar','cfzp',"$target/dirs/$rawdir.tar.gz","--exclude='*/proc'",$dir);
    
    They have the exclude in the wrong place. Note that they have also changed from double quotes (") to single quotes (').

    To test and see try both of these;

    tar --exclude=proc cfzp /test.tar.gz *

    tar cfzp /test.tar.gz --exclude=*/proc *

    The first one shows the error, the second one works.
     
    #6 dgbaker, Dec 4, 2005
    Last edited: Dec 4, 2005
  7. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
  8. stephem

    stephem Member

    Joined:
    Apr 25, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Line 344 has
    Code:
    cpusystem('rsync',$rsyncopts,"--exclude='*/proc'",'--delete',"$dir/","$target/dirs/$rawdir");
    Is that wrong as well?
     
  9. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    seems like almost a week now I am seeing these across all boxes as well
     
  10. stephem

    stephem Member

    Joined:
    Apr 25, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Made dgbaker's change but the nightly update overwrote it with the bugged version so still got the same errors. I suppose I will have to wait until CPanel correct it themselves.
     
  11. SubZero

    SubZero Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    100
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Balmumcu, Istanbul, TR
  12. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Seems they have "fixed" quite a few things lately without notifying of the changes. This is about the 5th thing we have seen in the past 2 weeks that really messed up Cpanel functionality.
     
  13. NightStorm

    NightStorm Well-Known Member

    Joined:
    Jul 28, 2003
    Messages:
    286
    Likes Received:
    4
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    So I'm curious... they apparently have not yet patched it, as I received the error again last night, instead of the standard email I used to receive prior to the update. Does this mean that my nightly backups are not infact being backed up?
    This is something I would like to know, so that I can use a secondary method of keeping a copy of the data on a second drive...
     
  14. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    This is the latest log for Edge. Should hit Current pretty soon I hope.

    10.8.1 (build 55) - EDGE Tree Linux i686 Thu Dec 8 21:37:58 2005

    Resolved bugzilla id 336 - Updated smartcheck to use later versions of
    smartmontools if installed
    Resolved bugzilla id 3208 - Change system mail preferences
    Resolved bugzilla id 3380 - BoxTrapper not working for domains that begin with
    a digit
    Resolved bugzilla id 3399 - maildir conversion on moved accounts
    Resolved bugzilla id 3427 - Disk quota in cPanel not updating immediately
    Resolved bugzilla id 3435 - FreeBSD 6.0 using tgz file extensions instead of
    tbz
    Resolved bugzilla id 3464 - Exim Configuration Editor generates an invalid
    configuration if smtp_banner is set
    Resolved bugzilla id 3518 - cpanelsync without bzip2 leaves -cpanesync.bz2
    files
    Resolved bugzilla id 3532 - Update yum.conf to exclude Exim rpm upgrades
    Resolved bugzilla id 3534 - Creation of Addon Domain with upper and lowercase
    does not work
    Resolved bugzilla id 3584 - cpbackup tar error
    Resolved bugzilla id 3587 - Urchin log processesing
    Resolved issue where resellers were unable to install new SSL certificates.
    Resolved issue where demo accounts' ftp login was re-enabled if the shell was
    changed from demoshell.
     
Loading...

Share This Page