The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpbackup script is not checking monthly Legacy backup

Discussion in 'Data Protection' started by armin654, Mar 27, 2014.

  1. armin654

    armin654 Well-Known Member

    Joined:
    Feb 12, 2014
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hello guys
    We use Legacy Backup configurations and we have enabled weekly and monthly backups

    Backups are being stores to a remote FTP destinations (on a connected LAN server)
    Some months as we check monthly backuped up files we realize that new monthly backups are not made.

    We check timestamp of monthly backup:
    #/home/cpbackuptmp/cpbackup/monthly/cpbackupstatus.cfg
    And unix time shows more than 1 month ago.

    We check the cpbackup logs on:
    #/usr/local/cpanel/logs/cpbackup/

    Surprisingly at it is obvious on log file, when cpbackup script runs, it only check the weekly backup and when it realizes that weekly backup is done in some days ago, it doesn't check the monthly backup timestamp to see whether it needs to start it or not.
    So monthly backup won't be checked and started!!

    Code:
    
    Net::FTP>>> Net::FTP(2.77)
    Net::FTP>>>   Exporter(5.66)
    Net::FTP>>>   Net::Cmd(2.29)
    Net::FTP>>>   IO::Socket::INET(1.31)
    Net::FTP>>>     IO::Socket(1.31)
    Net::FTP>>>       IO::Handle(1.28)
    Net::FTP=GLOB(0x270aa50)<<< 220-FileZilla Server version 0.9.41 beta
    Net::FTP=GLOB(0x270aa50)<<< 220-written by Tim Kosse (Tim.Kosse@gmx.de)
    Net::FTP=GLOB(0x270aa50)<<< 220 Please visit http://sourceforge.net/projects/filezilla/
    Net::FTP=GLOB(0x270aa50)>>> USER myuser
    Net::FTP=GLOB(0x270aa50)<<< 331 Password required for myuser
    Net::FTP=GLOB(0x270aa50)>>> PASS ....
    Net::FTP=GLOB(0x270aa50)<<< 230 Logged on
    Net::FTP=GLOB(0x270aa50)>>> QUIT
    Net::FTP=GLOB(0x270aa50)<<< 221 Goodbye
    [cpbackup] Setting I/O priority to reduce system load: best-effort: prio 3
    [cpbackup] backup point /home/cpbackuptmp/cpbackup/weekly is 3.67 days old
    [cpbackup] The following backups were already up to date: weekly
    [cpbackup] Completed at Fri Mar 28 01:00:05 2014
    
    


    I checked cpbackup.conf as well:
    Code:
    BACKUPRETWEEKLY 1
    PREBACKUP 0
    BACKUPINC no
    BACKUPLOGS no
    BACKUPMOUNT yes
    COMPRESSACCTS yes
    BACKUP2 yes
    BACKUPTYPE ftp
    LINKDEST no
    BACKUPFTPHOST XXX.XXX.XXX.XXX 
    MYSQLBACKUP accounts
    BACKUPRETDAILY 0
    BACKUPRETMONTHLY 1
    BACKUPDIR /
    BACKUPBWDATA no
    BACKUPFTPUSER MYUSERNAME
    BACKUPFTPTIMEOUT 120
    BACKUPDAYS 1,3,5
    GZIPRSYNCOPTS --rsyncable
    LOCALZONESONLY no
    BACKUPACCTS yes
    DIEIFNOTMOUNTED no
    USEBINARYPKGACCT no
    BACKUPFTPDIR /
    BACKUPENABLE yes
    BACKUPINT weekly
    BACKUPCHECK yes
    BACKUPFILES no
    POSTBACKUP 0
    BACKUPFTPPASSIVE no
    
    Everything seems fine but monthly backups are not being checked.
    Do you have any clue about this issue?

    My current solution is to force start cpbackup, but since it changes the time stamp to the current day we will have un-necessary weekly backups as well.

    I will be glad to hear a solution for this.
    Regards
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,724
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Is there any particular bug or concern that is preventing you from switching to the new backup system? It offers several performance and stability improvements that you might find useful.

    Thank you.
     
Loading...

Share This Page