The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CPbackup script timeout

Discussion in 'Data Protection' started by asfik, Dec 6, 2010.

  1. asfik

    asfik Member

    Joined:
    Mar 31, 2006
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Pamulang, Indonesia
    cPanel Access Level:
    Root Administrator
    Greeting,

    I have WHM backup configured to use remote FTP backup instead local backup. But I always got the following errors:

    Code:
    pkgacctfile is: /home/cpbackuptmp/cpbackup/daily/asfik.tar.gz
    md5sum is: 778d2546f3c638926891399ee2fcf7f8
    
    size is: 1422098
    Net::FTP=GLOB(0x14664f18)<<< 220 ProFTPD 1.3.2e Server (ProFTPD) [203.x.x.x]
    Net::FTP=GLOB(0x14664f18)>>> USER ftpbackup
    Net::FTP=GLOB(0x14664f18)<<< 331 Password required for ftpbackup
    Net::FTP=GLOB(0x14664f18)>>> PASS ....
    Net::FTP=GLOB(0x14664f18)<<< 230 User ftpbackup logged in
    Net::FTP=GLOB(0x14664f18)>>> TYPE I
    Net::FTP=GLOB(0x14664f18)<<< 200 Type set to I
    Net::FTP=GLOB(0x14664f18)>>> MKD cpbackup
    Net::FTP=GLOB(0x14664f18)<<< 550 cpbackup: File exists
    Net::FTP=GLOB(0x14664f18)>>> MKD cpbackup/daily
    Net::FTP=GLOB(0x14664f18)<<< 550 cpbackup/daily: File exists
    Net::FTP=GLOB(0x14664f18)>>> CWD cpbackup/daily
    Net::FTP=GLOB(0x14664f18)<<< 250 CWD command successful
    Net::FTP=GLOB(0x14664f18)>>> ALLO 1422098
    Net::FTP=GLOB(0x14664f18)<<< 202 No storage allocation necessary
    Net::FTP=GLOB(0x14664f18)>>> PASV
    Net::FTP=GLOB(0x14664f18)<<< 227 Entering Passive Mode (203,x,x,x,142,81).
    Net::FTP=GLOB(0x14664f18)>>> STOR asfik.tar.gz
    Net::FTP=GLOB(0x14664f18): Timeout at /scripts/cpbackup line 783
    Net::FTP=GLOB(0x14664f18)>>> QUIT
    Net::FTP=GLOB(0x14664f18): Timeout at /scripts/cpbackup line 784
    Net::FTP=GLOB(0x14664fc8)<<< 220 ProFTPD 1.3.2e Server (ProFTPD) [203.x.x.x]
    Net::FTP=GLOB(0x14664fc8)>>> USER ftpbackup
    Net::FTP=GLOB(0x14664fc8)<<< 331 Password required for ftpbackup
    Net::FTP=GLOB(0x14664fc8)>>> PASS ....
    Net::FTP=GLOB(0x14664fc8)<<< 230 User ftpbackup logged in
    Net::FTP=GLOB(0x14664fc8)>>> TYPE I
    Net::FTP=GLOB(0x14664fc8)<<< 200 Type set to I
    Net::FTP=GLOB(0x14664fc8)>>> MKD cpbackup
    Net::FTP=GLOB(0x14664fc8)<<< 550 cpbackup: File exists
    Net::FTP=GLOB(0x14664fc8)>>> MKD cpbackup/weekly
    Net::FTP=GLOB(0x14664fc8)<<< 550 cpbackup/weekly: File exists
    Net::FTP=GLOB(0x14664fc8)>>> CWD cpbackup/weekly
    Net::FTP=GLOB(0x14664fc8)<<< 250 CWD command successful
    Net::FTP=GLOB(0x14664fc8)>>> ALLO 1422098
    Net::FTP=GLOB(0x14664fc8)<<< 202 No storage allocation necessary
    Net::FTP=GLOB(0x14664fc8)>>> PASV
    Net::FTP=GLOB(0x14664fc8)<<< 227 Entering Passive Mode (203,x,x,x,188,24).
    Net::FTP=GLOB(0x14664fc8)>>> STOR asfik.tar.gz
    Net::FTP=GLOB(0x14664fc8): Timeout at /scripts/cpbackup line 783
    Net::FTP=GLOB(0x14664fc8)>>> QUIT
    Net::FTP=GLOB(0x14664fc8): Timeout at /scripts/cpbackup line 784
    [cpbackup] Copying daily backups to weekly backups for retention
    [cpbackup] The following backups were already up to date: monthly
    [cpbackup] Completed at Sat Dec  4 02:28:08 2010
    
    I am not sure where caused this issue. I've try using ftp command line manually and everything looks fine, even with bigger file size. I also increasing remote Proftpd timeout setting, but it doesn't help much.

    Please let me know if you have experiencing this issue and how to fix this. Any comments are greatlt appreciated.

    Thank you.

    Regards,
    Asfihani
     
  2. syslint

    syslint Well-Known Member

    Joined:
    Oct 9, 2006
    Messages:
    249
    Likes Received:
    6
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Do you have any firewall installed , if so try to white list ftp server IP too.
     
  3. asfik

    asfik Member

    Joined:
    Mar 31, 2006
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Pamulang, Indonesia
    cPanel Access Level:
    Root Administrator
    Hi syslint,

    Thank you for your valuable comment. Actually the remote FTP server is a server running Pl*sk. I have add the IP to firewall whitelist, see if this can solve the issue. I just wonder why with ftp with command line just work. I am curious about a passive port that used by Net::FTP (used by cpbackup script) was blocked by Pl*sk firewall.

    Will let you know the update.

    Thank you.

    Regards,
    Asfihani
     
  4. asfik

    asfik Member

    Joined:
    Mar 31, 2006
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Pamulang, Indonesia
    cPanel Access Level:
    Root Administrator
    [SOLVED] Re: CPbackup script timeout

    Hello,

    Just let you know that the issue was resolved by whitelisting WHM IP address in firewall.

    Thank you.

    Regards,
    Asfihani
     
Loading...

Share This Page