cPhulkd Error Log takes too much space

rpvw

Well-Known Member
Jul 18, 2013
1,101
458
113
UK
cPanel Access Level
Root Administrator
Do make sure you have cphulkd.log and cphulkd_errors.log checked as in rotation :
Home » Service Configuration » cPanel Log Rotation Configuration

Also check that your Tweak Settings >> Log Rotation Size Threshold is set to a size consistent with your available space. (The default is 300MB)

See cPanel Log Rotation Configuration for more information.
 
Last edited:
  • Like
Reactions: cPanelMichael

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Hello,

Could you also check the file attributes on that log file? EX:

Code:
lsattr /usr/local/cpanel/logs/cphulkd_errors.log
Thank you.
 

Tommy Pro

Member
Jul 17, 2017
7
0
1
Indonesia
cPanel Access Level
Root Administrator
Do make sure you have cphulkd.log and cphulkd_errors.log checked as in rotation :
Home » Service Configuration » cPanel Log Rotation Configuration

Also check that your Tweak Settings >> Log Rotation Size Threshold is set to a size consistent with your available space. (The default is 300MB)

See cPanel Log Rotation Configuration for more information.
Hi Rpvw, thanks for replying. I just untick log rotation for cphulkd.log and cphulkd_errors.log.

Log rotation size threshold is on default ( 300MB ).

Can i just delete that file now?
 

rpvw

Well-Known Member
Jul 18, 2013
1,101
458
113
UK
cPanel Access Level
Root Administrator
I do NOT recommend that you take the files out of rotation, nor that you attempt to delete them yet.

I would recommend you first ascertain as to why the files are not being rotated.

It is always possible that cPanel is not handling the rotation correctly.
Personally, I cannot see any entry in my /etc/logrotate.conf nor in /etc/logrotate.d associated with cphulk.
On this basis, I have to assume that cPanel is using some other totally distinct process (cpanellogd daemon ?) to handle the cphulk (and others) log rotation, OR that there is a fundamental issue with the log rotation scripting and integration with logrotate.d

It is also possible that your log is growing unusually quickly for some reason. Since it seems to be rotated only once at the end of each month, it may have not been rotated yet. Have you checked to see if there are any older rotated log files in the /usr/local/cpanel/logs/archive/ directory ?

Perhaps you should open a support ticket and get an opinion straight from developers.
 
Last edited:

Tommy Pro

Member
Jul 17, 2017
7
0
1
Indonesia
cPanel Access Level
Root Administrator
I do NOT recommend that you take the files out of rotation, nor that you attempt to delete them yet.

I would recommend you first ascertain as to why the files are not being rotated.

It is always possible that cPanel is not handling the rotation correctly.
Personally, I cannot see any entry in my /etc/logrotate.conf nor in /etc/logrotate.d associated with cphulk.
On this basis, I have to assume that cPanel is using some other totally distinct process (cpanellogd daemon ?) to handle the cphulk (and others) log rotation, OR that there is a fundamental issue with the log rotation scripting and integration with logrotate.d

It is also possible that your log is growing unusually quickly for some reason. Since it seems to be rotated only once at the end of each month, it may have not been rotated yet. Have you checked to see if there are any older rotated log files in the /usr/local/cpanel/logs/archive/ directory ?

Perhaps you should open a support ticket and get an opinion straight from developers.
The rotation was ticked in the first place, i manually untick those. Okay thanks Rpvw
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Hello,

Could you open a support ticket using the link in my signature so we can take a closer look to see why that log isn't rotated?

Thank you.
 

Tommy Pro

Member
Jul 17, 2017
7
0
1
Indonesia
cPanel Access Level
Root Administrator
Hello,

Could you open a support ticket using the link in my signature so we can take a closer look to see why that log isn't rotated?

Thank you.
Hi Michael, it was in the first place, as i said before i manually untick the rotation and at the end i return to its default setting which is ticked.

The problem was not the rotation ( i think ).
But the file size of the error logs, i already opened a support ticket and jack is currently on it.

Thanks for replying!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Hello,

Could you post the ticket number here so we can update this thread with the outcome?

Thanks!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Hi Tommy,

It's safe to post the ticket number, but I was actually able to find the support ticket so it's no longer required. I'll monitor the ticket and update this thread with the outcome.

Thanks!
 

abdelhost77

Well-Known Member
Apr 25, 2012
116
2
68
Morocco
cPanel Access Level
Root Administrator
Hi CpanelMichael ,

what is the solution please to that pb? i have the same , log file more than 10G , and wont be deleted .

[/usr/local/cpanel/logs]# lsattr /usr/local/cpanel/logs/cphulkd_errors.log
-----a-------e- /usr/local/cpanel/logs/cphulkd_errors.log
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,257
313
Houston
Hi @abdelhost77

The attributes of that file are standard - looking at my own it's as follows:
Code:
# lsattr /usr/local/cpanel/logs/cphulkd_errors.log
-----a-------e-- /usr/local/cpanel/logs/cphulkd_errors.log
Can you tell me if cphulkd_errors.log is configured in WHM>>Service Configuration>>cPanel Log Rotation Configuration and what the Log Rotation Size Threshold is set to at WHM>>Server Configuration>>Tweak Settings

Thanks!