The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cphulkd rejected registration attempt for whostmgrd with: 500 AUTH FAILED

Discussion in 'General Discussion' started by plheric, Jan 14, 2013.

  1. plheric

    plheric Registered

    Joined:
    Jan 14, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi all ,

    I have 2 server
    ns1: WHM web server (synchronize changes)
    ns2: cPanel DNSOnly server (Backup DNS zones) (Standalone)

    I have followed the setup DNS cluster guide , and everything reported OK after click the Synchronize button .
    The problem is : WHM server didn't synchronize dns zones to cPanel DNSOnly . I checked /usr/local/cpanel/log/error_log on cPanel DNSOnly , and saw this :

    cphulkd rejected registration attempt for whostmgrd with: 500 AUTH FAILED

    cphulkd rejected registration attempt for whostmgrd with: 500 AUTH FAILED

    cphulkd rejected registration attempt for whostmgrd with: 500 AUTH FAILED

    cphulkd rejected registration attempt for whostmgrd with: 500 AUTH FAILED

    cphulkd rejected registration attempt for whostmgrd with: 500 AUTH FAILED

    I thought this problem cause by the "remote access key" , so I tried /script/upcp --force , then regenerate "remote access key" and configured 2 servers again . But still couldn't solve the problems above . I have tried /script/dnscluster syncall also . The dns report keep warning "nameservers are lame" at ns2 .

    Finally I copied the named.conf from WHM server to cPanel DNSonly , and dns report looks OK now , but I still keep getting this error on cPanel DNSOnly :

    cphulkd rejected registration attempt for whostmgrd with: 500 AUTH FAILED

    cphulkd rejected registration attempt for whostmgrd with: 500 AUTH FAILED

    cphulkd rejected registration attempt for whostmgrd with: 500 AUTH FAILED

    cphulkd rejected registration attempt for whostmgrd with: 500 AUTH FAILED

    cphulkd rejected registration attempt for whostmgrd with: 500 AUTH FAILED

    What is this error about ? I saw in the change-log it was fix in WHM 11.32 (all my servers is 11.34.1) . Is that mean my WHM server cannot access to cPanel DNSOnly server ?

    Please help me . Thanks a lot !
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,694
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Re: cphulkd rejected registration attempt for whostmgrd with: 500 AUTH FAIL

    Hello :)

    Could you submit a ticket so we can take a closer look? You can submit a ticket via:

    Submit A Ticket

    You can post the ticket number here so we can track the issue.

    Thank you.
     
  3. edigest

    edigest Active Member

    Joined:
    Nov 24, 2010
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    S. Pole
    cPanel Access Level:
    Root Administrator
    Did you find the reason for this and can you post it here? I have the same problem on a new DNS-Cluster server.
     
    #3 edigest, Jun 5, 2014
    Last edited: Jun 5, 2014
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,694
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    What version of cPanel is installed on your hosting machine? I presume that cPhulk is enabled?

    Thank you.
     
  5. edigest

    edigest Active Member

    Joined:
    Nov 24, 2010
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    S. Pole
    cPanel Access Level:
    Root Administrator
    There are two servers connected to the DNS-only cluster and both are running WHM 11.42.1 (build 17). Both are experiencing this issue with (only) one of the servers in the DNS cluster.

    Interestingly, I get a cPhulk brute-force notification coincident with the 500 errors. The DNS server is disconnected from the cluster, but I don't know if the disconnect occurs before or after the cPhulk notification. (The log times for the cPhulk notification begin a few seconds after the 500 errors.)

    There is no discrepancy with the server times. The authentication error clears up on its own some time later with no changes to the remote access key before or after the incidents.

    I've whitelisted the server IPs in cPhulk on the "bad" server to rule out a cPhulk problem.
     
    #5 edigest, Jun 6, 2014
    Last edited: Jun 6, 2014
Loading...

Share This Page