Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED cphulkd service is down

Discussion in 'General Discussion' started by ddaddy, May 9, 2017.

Tags:
  1. ddaddy

    ddaddy Active Member

    Joined:
    Aug 19, 2015
    Messages:
    29
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Today I changed a couple of settings.
    I set `PermitRootLogin without-password` in my sshd_config
    I enabled 2 factor authentication
    I enabled SMTP Restrictions
    and finally as instructed by the Security Advisor page, I performed a graceful restart so some updated stuff can restart.

    Since making these changes I am getting many emails saying that cphulkd service is down.
    Every now and then i'll get one saying it's RECOVERED, shortly followed by more saying it's down again.

    The reason it gives is: Service check failed to completecphulkd: [HTTP/1.1 500 != HTTP/1.. 200]

    and the log message: The system could not provide log messages for “cphulkd” because it failed to read all of the potential log files with the following errors: Error while attempting to read “/var/log/maillog”: “Empty File”, Error while attempting to read “/var/log/messages”: “Empty File”, Error while attempting to read “/var/log/secure”: “Empty File”

    Any idea what's caused this and how to fix it?

    Thanks
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Internal case CPANEL-12937 is open to address an issue where Chkservd continuously restarts cPhulkd. Affected systems will notice output like this in the /var/log/chkservd.log file:

    Code:
    cphulkd [Service check failed to completecphulkd: [HTTP/1.1 500 != HTTP/1.. 200]
    I'll update this thread again once we publish a resolution for this issue. In the meantime, the temporary workaround is to disable monitoring for the "cPHulk Daemon" service via "WHM >> Service Manager".

    Thank you.
     
  3. ddaddy

    ddaddy Active Member

    Joined:
    Aug 19, 2015
    Messages:
    29
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Funny enough, the alerts have stopped today. I wonder if an overnight update has fixed it.

    And I don't have a `chkservd.log` file in `/var/log/`
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Restarting cPHulk may have synced the authentication keys and fixed the issue on your system. Internal case CPANEL-12937 will prevent this from happening in the future.

    Thank you.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    This was fixed in cPanel version 64.0.22:

    Fixed case CPANEL-12937: Solve out of sync 500 errors with cphulkd.

    Thank you.
     
Loading...

Share This Page