The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpmove cpu overload

Discussion in 'Workarounds and Optimization' started by PatrickVeenstra, Jun 16, 2016.

  1. PatrickVeenstra

    PatrickVeenstra Well-Known Member

    Joined:
    Feb 12, 2012
    Messages:
    70
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Barcelona
    cPanel Access Level:
    Root Administrator
    When I make a cpmove file from the command line the server stops responding during the compression of the homedir. pigz is overloading the cpu.

    - Can I bind the entire cpmove process or at least pigz to a single cpu core? I don't care about the time it takes to create the backup.
    - Is it possible to make a cpmove without compression?
    - If I modify the pigz compression ratio in WHM (Tweak Settings) will that affect creating a cpmove from the command line?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    The following options are available under the "Compression" tab in "WHM >> Tweak Settings", and they affect both manual uses of Pkgacct and automatic backups configured in WHM.

    gzip compression level
    Number of pigz processes
    Number of kilobyte chunks per compression work unit

    The "--nocompress" flag is also available when using the Pkgacct script, as documented at:

    https://documentation.cpanel.net/pages/viewpage.action?pageId=1507332

    Thank you.
     
Loading...

Share This Page