The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cppop failed

Discussion in 'General Discussion' started by adapter, Apr 5, 2004.

  1. adapter

    adapter Well-Known Member
    PartnerNOC

    Joined:
    Sep 17, 2003
    Messages:
    391
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    evry day i receive the email from whm:

    cppop failed @ Mon Apr 5 12:27:01 2004. A restart was attempted automagicly.

    what can be the cause of this crash??
     
  2. beachtrader

    beachtrader Active Member

    Joined:
    Feb 21, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Are you using a FreeBSD server?

    We have this problem on our FreeBSD servers with cppop constantly failing and having to be restarted. This only occurred with the update to the most recent stable after upgrading from 8.5.

    It's been a week with tickets open and the problem is still not resolved.
     
  3. wimp

    wimp Well-Known Member

    Joined:
    Jul 13, 2002
    Messages:
    301
    Likes Received:
    0
    Trophy Points:
    16
    have the same problem here but with:
    WHM 9.2.0 cPanel 9.3.0-R5
    RedHat 9 - WHM X v3.1.0

    is there any fix out for this problem?

    thanks
     
  4. rasilva

    rasilva Member

    Joined:
    Mar 18, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Yeah... finally, found someone with same problem.

    My CPPOP restarts every single day. Most of the times it's just once per day... but in some days can be 2 or 3 times.

    My system is:

    RH 9 - Kernel 2.4.22-1.2188.nptl (FEDORA)
    Cpanel 9.3.0-RELEASE_5

    HELP!
     
  5. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    cppop can die if it is getting hammered and you have a max connections per hour set in the WHM tweak settings. This problem has persisted for months.
     
  6. wimp

    wimp Well-Known Member

    Joined:
    Jul 13, 2002
    Messages:
    301
    Likes Received:
    0
    Trophy Points:
    16
    i had, for another problem, to rebuild apache. Afther the rebuild ccpop doesn't fail anymore...


    :)
     
  7. rasilva

    rasilva Member

    Joined:
    Mar 18, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    jsteel,

    so if you remove the "per hour limit" from WHM, does it stop?

    thanks.
     
  8. wimp

    wimp Well-Known Member

    Joined:
    Jul 13, 2002
    Messages:
    301
    Likes Received:
    0
    Trophy Points:
    16
    grrr........ccpop just failed again....
    :mad:
     
  9. rasilva

    rasilva Member

    Joined:
    Mar 18, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    wimp,

    try to increase the "per hour" limit in WHM... i have done it and so far so good. will keep you posted if it starts acting again.
     
  10. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    I just increased mine too. However, this will defeat the purpose as if it fails and restarts, then it does not prevent
    the hourly limit.
     
  11. rasilva

    rasilva Member

    Joined:
    Mar 18, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    easyhoster1,

    yes, of course.... totally agree with you but at least you know where the problem is and hopefully we can open a bug reports at cpanel support site and have them fix it.
     
  12. beachtrader

    beachtrader Active Member

    Joined:
    Feb 21, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Actually the problem on my servers does not appear to be the max connections. I wrote a script to monitor the processes by cppop and restart it if necessary. I have watched it for weeks now and when it fails there are not a lot of cppop requests going on.

    Here is the script. It basically checks to see if cppop is running every 30 seconds and restarts if it has failed:

    Code:
    #!/usr/bin/perl
    
    my $x = 1;
    
    while ($x > 0) {
    
    sleep 30;
    
    my $string = `ps -aux | grep cppop`;
    if ($string =~ /.accepting on port 110/ ) {print "cppop running. \n $string"}
    
    else {`/scripts/ckillall -9 cppop;/usr/local/cpanel/bin/cppop`; print "cppop restarted. /n"};
    
    };
    
     
  13. wimp

    wimp Well-Known Member

    Joined:
    Jul 13, 2002
    Messages:
    301
    Likes Received:
    0
    Trophy Points:
    16
    "beachtrader" where do i nedd to put this script in order to work?

    I will also upgrade to the latest stable vers.of CPanel I am currently on the latest Release.

    "rasilva" I dont like to increase "per hour" limit in WHM as this may let send customers tons of messages.... but pleae let me know whats' going on.

    BTW Anyone open a ticket for the ccpop problem?

    Thanks
     
  14. beachtrader

    beachtrader Active Member

    Joined:
    Feb 21, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Hi:

    You can put the script anywhere--it just needs to be run as root.

    I put in multiple tickets months ago. Basically, cPanel said it was my server's problems (they said hardware issues). But it only happened after upgrading. Since then they have tried upgrading to the latest edge releases every now and then and it has helped, but not solved the issue.
     
  15. web12

    web12 Well-Known Member

    Joined:
    Nov 20, 2002
    Messages:
    240
    Likes Received:
    0
    Trophy Points:
    16
    Strange, im getting this across 4 servers now after upgrading to 9.4.1-RELEASE_55

    Whats the deal with this?
     
  16. punk

    punk Member

    Joined:
    Jun 20, 2002
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    I had the same problems after upgrade to cPanel 9.4.1-R55 (I received more than 20 emails that say my cppop is failed & restarted).

    I think it's a bug from cpanel, so I open a new support ticket to them. From their answer + a little experiment, my cppop running well again.

    PLEASE don't forget to backup you cppop + do this with your own risk !!

    Downgrading cppop binary:

    (SSH/su as root)
    cd /usr/local/cpanel/bin
    killall cppop
    (verify that there are no cppop processes)
    mv cppop cppop.BAD
    wget http://ozukira.cpanel.net/cppop
    md5sum cppop
    (should report f40038d2f564d4cad00b610ee1d7f6de if not refetch)
    chmod 755 cppop
    chown root:root cppop
    chattr +i cppop
    /usr/local/cpanel/startup
    (Done)

    Once again, do it with Your Own Risk !!! and don't forget to backup your cppop before, so you can restore it again if the process above is failed.

    Hope this can help :)
     
  17. web12

    web12 Well-Known Member

    Joined:
    Nov 20, 2002
    Messages:
    240
    Likes Received:
    0
    Trophy Points:
    16
    Thanks Punk, will try that now!
     
  18. punk

    punk Member

    Joined:
    Jun 20, 2002
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    np :) let me know for the result
     
  19. web12

    web12 Well-Known Member

    Joined:
    Nov 20, 2002
    Messages:
    240
    Likes Received:
    0
    Trophy Points:
    16
    Well, so far so good... 24 hours and no CPPOP emails.

    Thanks buddy. :)
     
  20. blaze64

    blaze64 Well-Known Member

    Joined:
    Feb 5, 2003
    Messages:
    159
    Likes Received:
    0
    Trophy Points:
    16
    Something is amiss with ccpop, regardless of what Nick says. I am having issues with it on 4 servers (out of 13). I notice that the date/time changed was about the same time I did a /scripts/easyapache recompile...?? These are the only servers that I am having problems with as well.

    I put caution to the wind and used your version of cppop.... we will see how it goes.

    Thanks for the fix... I will report back in 24 hours to let you (and others) know how it worked.
     
Loading...

Share This Page