hwicpanel

Registered
Dec 14, 2004
2
0
151
I am having a problem getting pop connection to our server here.

When I login to the server and try to restart the service, here is the error I am getting.

./restartsrv_cppop
Waiting for cppop to shutdown ... ...Done
Waiting for cppop-ssl to shutdown ... ...Done
[email protected] [/scripts]#
@[email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected]
@! ATTENTION! mbox is deprecated in this release [email protected]
@[email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected]
@ You should switch to using maildir as soon as @
@ possible. To switch run @
@ /scripts/convert2maildir @
@ in a root shell. @
@[email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected][email protected]

Normal Startup Proceeding.
Undefined subroutine &main::getsysid called at bin/cppop-ssl.pl line 1892.


Should I do the upgrade or continue to try and troubleshoot this issue?

Any ideas how to repair or where the cppop-ssl.pl file is (I cannot find it by doing a locate on the server).

Thank you.
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
I know a few days ago there were some issues with cppop. Try updating your cPanel and see if the issue is resolved. If not, submit a support ticket: http://tickets.cpanel.net

Note, cppop is only used by the servers still using the antiquated mbox format. mbox will be fully deprecated in version 12. We offer free assistance with migrating from mbox to maildir, see the interactive script /scripts/convert2maildir for information.

If you attempt to do the conversion now, please do not terminate the process even if it appears hung and it has been working for a day or two. I recommend planning to do this when the server has a minimal email load as email will be queued (not delivered) during the conversion process to prevent data loss.
 
Thread starter Similar threads Forum Replies Date
Z Email 3
I Email 5
big_bull Email 1
L Email 4
rpmws Email 16