The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpsrvd crashing, any fixes yet?

Discussion in 'General Discussion' started by LP-Trel, Mar 18, 2004.

  1. LP-Trel

    LP-Trel Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nirvana
    cpsrvd core dumping, any fixes yet?

    My cpsrvd keeps crashing at somewhat random times and I get the emails:

    cpsrvd failed @ Thu Mar 18 20:36:20 2004. A restart was attempted automagicly.

    Is there any fix on this?

    cPanel.net Support Ticket Number: http://bugzilla.cpanel.net/show_bug.cgi?id=8
     
    #1 LP-Trel, Mar 18, 2004
    Last edited: Mar 22, 2004
  2. PbG

    PbG Well-Known Member

    Joined:
    Mar 11, 2003
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    I believe the changelog or WHM news mentioned something about rebooting if you were having a problem with this and/or getting the old dameon to stop.
     
  3. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    I ran a few scripts and also tried restarting the server yesterday (resulting in 13 mins of downtime) and the problem is still occuring. I also opened a ticket yesterday with cpanel and still haven't heard anything back.
     
  4. Mani

    Mani Well-Known Member

    Joined:
    Dec 22, 2003
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    16
    any chance you are with RHE with hyperthreading box
     
  5. bjdea1

    bjdea1 Well-Known Member

    Joined:
    Mar 6, 2003
    Messages:
    83
    Likes Received:
    1
    Trophy Points:
    8
    Same prob here

    I'm having the same problem and I've only noticed it now after trying to upgrade a whole lot of accounts. Each account upgrade is taking about 2 mins (forever). Then if I look at Service status I see cpsrvd has failed.
     
  6. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    I'm running FreeBSD 4.7.
     
  7. strongbow

    strongbow Member

    Joined:
    Dec 2, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Nottingham UK
    Got the same problem here

    WHM 9.1.0 cPanel 9.1.0-R85
    RedHat 9 - WHM X v2.1.2

    server was installed about a week ago, and kernel upgraded and RH patches installed Sunday and then the problem started at first was showing in the service status that apache, cppop and cpsrvd had failed.

    But all worked fine, moved to teh Release version and this cleared up the screen and evertthing was fine till around 5am this morning and now a mail at various times but at least once per hour.
     
  8. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    I've had a ticket open for about 4 days and still haven't heard anything back. I guess they have no idea how to fix this problem??? I wish something would be done about it. I get an email every 8 minutes notifying me that cpsrvd is down and it is really annoying.
     
  9. strongbow

    strongbow Member

    Joined:
    Dec 2, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Nottingham UK
    I have also opened a support ticket, this is the first time I have used the support for this product as I have found answers to all my other questions/problems in these forums so I hope I get a reply faster than 4 days.

    cPanel.net Support Ticket Number: cPanel ID# 44027
     
  10. LP-Trel

    LP-Trel Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nirvana
    You can read the bug report here:

    http://bugzilla.cpanel.net/show_bug.cgi?id=8

    It seems that cpsrvd isn't just crashing, its core dumping. Check your /var/log/messages to see if yours is.

    I hope they answer faster than 7 days. 17-22 is 5, two left.. :rolleyes:
     
  11. strongbow

    strongbow Member

    Joined:
    Dec 2, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Nottingham UK
    I had a response from support earlier requesting login details to which i have replied and had not response back.

    Before I recived the response from support the server stopped sending the e-mails and I have now not received one since 13:11:27 GMT today.

    I scanned though my logs and can't find anything like you have in yours LifelessHost.

    Though I have found something strange, these messages have been constent since 08:45 21/3/04

    Mar 22 03:08:43 host1 proftpd[25093]: xxx.xxx.13.250 (localhost[127.0.0.1]) - FTP session opened.
    Mar 22 03:08:43 host1 proftpd[25093]: xxx.xxx.13.250 (localhost[127.0.0.1]) - FTP session closed.

    This is a box on my network but as far as i am aware there is NO reason why either of them should be trying to ftp I have modernbill setup on 13.250 but at the min I have not had chance to set this up.

    can anyone think of any other reason ?
     
    #11 strongbow, Mar 22, 2004
    Last edited: Mar 22, 2004
  12. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    Here's a "kicker" follow-up.

    On our RHEL ES boxes, if we reboot the machine, chkservd restarts cpsrvd automatically about every 30 minutes after the reboot occurs. If we then run /scripts/upcp, it forces one last restart and things subside (even if no new version is downloaded). Quite odd.

    But as with the rest of you, we also have the random cpsrvd dumps on all Red Hat 7.3, 8.0 and 9 servers at random intervals.

    We are currently at R85 on all servers.
     
  13. LP-Trel

    LP-Trel Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nirvana
    Still happening here.. :mad:
     
  14. pfmartin

    pfmartin Well-Known Member

    Joined:
    Aug 18, 2001
    Messages:
    167
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
  15. tvcnet

    tvcnet Well-Known Member
    PartnerNOC

    Joined:
    Aug 15, 2003
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Diego
    cPanel Access Level:
    DataCenter Provider
    Ditto here as well.
    I'm getting quite concerned.

    Thanks,
    Jim
     
  16. Tina

    Tina Well-Known Member

    Joined:
    Jan 27, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    cpsrvd crashing and errors

    My server too.

    I restarted cpanel
    /etc/rc.d/init.d/cppanel restart

    and all's well now.


    Tina
     
    #16 Tina, Mar 24, 2004
    Last edited: Mar 25, 2004
  17. parasane

    parasane Well-Known Member

    Joined:
    Oct 19, 2003
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Dickson City, Pennsylvania (USA)
    Here's a question....

    For our server, it seemingly occurs when > 1 user is logged in under the same UID. For example, my partner is in San Diego, California, and I am in Olyphant (near Scranton), Pennsylvania. Obviously, we're not on the same network. If we both log in as admin, cpsrvd crashes. However, if only one user is logged in as admin, it's fine.

    If someone could run a proof-of-concept using a different login and multiple users logged in under that UID and report back, it may solve the bug here.

    Another note: while >1 (GUID && GUID) try Horde. That seemed to be the real killer, when we were both trying to log in to Horde using the same cPanel GUID, but separate mail ID's.
     
  18. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    450
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    All over!
    This has happended to use 3 times today at 1:21pm, 6:06pm & 8:37pm. I was logged into WebMail when this happened the first time. We are running the below on our server. When is cPanel going to fix this???????

    WHM 9.1.0
    cPanel 9.1.0-E200
    RedHat 9
    WHM X v2.1.2
     
  19. evisions

    evisions Well-Known Member

    Joined:
    Jan 25, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Is there any word on this issue yet? This has started occuring for me after I did a server upgrade this past weekend. Seems to be happening a couple of times a day right now....
     
  20. shaky

    shaky Well-Known Member

    Joined:
    May 31, 2003
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Same here I get an error message precisely every 10 minutes.

    The really weird thing is that the error messages are:

    "cpsrvd on server1.resellerdomain.net failed"

    But my server hostname is: server67.domain.com

    and resellerdomain.net is just one of myb resellers....:confused:
     
Loading...

Share This Page