cpsrvd failed. A restart was attempted automagically.

cyberjacob

Registered
Aug 2, 2013
1
0
1
cPanel Access Level
DataCenter Provider
Hi All,

I keep recieving the following emails from my cPanel/WHM server:

WHM said:
cpsrvd failed @ Fri Aug 2 09:27:10 2013. A restart was attempted automagically.

Service Check Method: [socket connect]

Reason: Timeout while trying to connect to service: Died at /usr/local/cpanel/Cpanel/TailWatch/ChkServd.pm line 558.


Number of Restart Attempts: 7

Startup Log: Waiting for cpsrvd to shutdown ... ...Done Waiting for cpsrvd-ssl to shutdown ... ...Done Waiting for whostmgrd to shutdown ... ...Done Starting cpsrvd.
As far as I can tell, the server is running normally.
Is this something to be worried about? If not, how can I stop the messages? If it is, how can I fix it?

Thanks!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Hello :)

Do you have a loopback device (127.0.0.1) bound to the server? You can check this with a command such as:

Code:
ifconfig
Do you see a device for 127.0.0.1 when running this command?

Thank you.
 

davorg

Active Member
May 13, 2013
32
3
58
cPanel Access Level
Root Administrator
Hello

Have you resolved this issue? It happened same to me tonight. Server has send 150 mail. Loopback device has been up and status of all services has been GREEN. Everything is working, but mail has been delivered every few minutes. Then I have restart server and now everything works ok. This happened to me every 3 or 4 months without any reason.

Any idea?

-- Davor
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Please open a support ticket if the issue continues so we can take a closer look:

Submit A Ticket

You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

davorg

Active Member
May 13, 2013
32
3
58
cPanel Access Level
Root Administrator
Today I have the same error. I have restarted server and now will everything be OK for next 3 months. I have latest version of cPanel. Any Idea?

Regards,

-- Davor
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Today I have the same error. I have restarted server and now will everything be OK for next 3 months. I have latest version of cPanel. Any Idea?
Were you able to submit a support ticket so we could investigate the issue further?

Thank you.