The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpsrvd failing frequently.

Discussion in 'Data Protection' started by salman77, Aug 10, 2006.

  1. salman77

    salman77 Registered

    Joined:
    Aug 10, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    The services are failing frequently, almost everyday I have reboot my server, Can any one suggest me something to resolve this. The messages from the server are given below.

    cpsrvd failed @ Thu Aug 10 12:15:30 2006. A restart was attempted
    automagicly.

    eximstats failed @ Thu Aug 10 12:15:30 2006. A restart was attempted
    automagicly.

    ftpd failed @ Thu Aug 10 12:15:30 2006. A restart was attempted
    automagicly.

    mysql failed @ Thu Aug 10 12:15:30 2006. A restart was attempted
    automagicly.


    Please help me out..

    Regards,
    Salman.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you reboot your server, that will happen as chkservd usually has to restart the services itself after a reboot.
     
  3. salman77

    salman77 Registered

    Joined:
    Aug 10, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    every service is failing


    Almost every service is failing(spamd, mysqld, ftpd, etc), and I could not even ssh it. I have to request the datacenter people to restart it everyday. I want to get rid of this, I dont understand why the services are failing. The server load is also almost 0.0 . Can anyone please tell me how to rectify it as I am newbie.

    Regards,
    Salman.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You'll have to go through the server logs, especially the messages log and look for problems. Also, watch top on the server and see if the server starts swapping heavily which could be the problem - i.e. not enough physical RAM for what you're trying to get the server to do.

    Also, if it always happens at a particular time of day, when? Is it when a cron job runs, for example the cPanel backups?

    Lastly, make sure you do not have the laus rpm installed and if you do, search the forums on how to properly remove it.
     
  5. salman77

    salman77 Registered

    Joined:
    Aug 10, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    IMAP is not starting.


    Hi,
    The server log doesnot have anything worth noting, However, IMAP is not starting though after several restart automatically by script and server reboots. I tried to start it manually from /scripts/restartsrv_imap but its still not starting. I suspect its corrupt. How can I restore it, can I install it from any rpm, or do I have to report cpanel or datacenter for restoring.


    Moreover, laus rpm is not seem to be in my system.

    This command did not return any value.
    # rpm -qa | grep laus

    please help.



    regards,
    Qadir.
     
  6. fleksi

    fleksi Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    16
    cpsrvd timeout

    chkservd on my server detected cpsrvd timeout that causing cpanel restart more frequently.
    How to resolved this problem?

    10.9.0-STABLE_58 on RHEL 3

    Thank you
     
  7. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Same here..it fails frequently
     
  8. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    Someone did find a solution?

    I did upgrade to cPanel 10.9.0-R79 and the problem continue

    cpsrvd is timing out...

    Service check ....antirelayd [+]...clamd [+]...cpsrvd [TIMEOUT!!!! on send

    Thanx!
     
  9. forlinuxsupport

    forlinuxsupport Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2004
    Messages:
    386
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    try /scripts/upcp --force

    that will force update and might fix your problem :)

    andy
     
  10. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    yep...as usual --force did the trick

    Thanx!
     
  11. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    nope...it worked for feww minutes and start failing again :-(

    any other idea?

    Thanx!
     
  12. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Still FAILING
     
  13. JVSInternet

    JVSInternet Registered

    Joined:
    Dec 18, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Failing here too, then ftpd, and mysql fails too. var/log/message shows nothing important. Please advise on how to fix this issue, thanks.
     
  14. hikaro

    hikaro Well-Known Member

    Joined:
    Nov 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    16
    anyone fix this issue? if yes please do reply so let us know.
    thanks
     
  15. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    Let's backup a bit here ...

    Are you running a VPS or Dedicated server?

    How much memory do you have?
     
  16. hikaro

    hikaro Well-Known Member

    Joined:
    Nov 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    16
    dedicated server
    2GB ECC ram
     
  17. vagsoftware

    vagsoftware Active Member

    Joined:
    Oct 20, 2006
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Wassup!

    2 issues!

    1. Hardware failure. If your system is stable under havy load, this is not the problem.

    2. /proc filesystem

    Verify the processes!

    Respekt.
     
Loading...

Share This Page