The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpsrvd keeps starting on v56

Discussion in 'General Discussion' started by dvk01uk, Apr 26, 2016.

  1. dvk01uk

    dvk01uk Registered

    Joined:
    Oct 20, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I see this in the logs very frequently
    is it a feature of 11.56
    I can't see any real reason why cpsrvd should be continually starting. I thought it was running all the time

    Code:
    [2016-04-26 16:35:42 +0100] info [whostmgr] Whostmgr::Services::_restart_services: mailscanner
    ==> cpsrvd 11.56.0.8 started
    ==> cpsrvd: loading security policy....Done
    ==> cpsrvd: Setting up native SSL support ... Done
    ==> cpsrvd: transferred port bindings
    ==> cpsrvd: bound to ports
    [2016-04-26 17:09:04 +0100] info [cphulkd] cPHulk::BruteForce Notification => [redacted].***** via EMAIL [eventimportance => Low (3)]
    ==> cpsrvd 11.56.0.8 started
    ==> cpsrvd: loading security policy....Done
    ==> cpsrvd: Setting up native SSL support ... Done
    ==> cpsrvd: transferred port bindings
    ==> cpsrvd: bound to ports
    ==> cpsrvd 11.56.0.8 started
    ==> cpsrvd: loading security policy....Done
    ==> cpsrvd: Setting up native SSL support ... Done
    ==> cpsrvd: transferred port bindings
    ==> cpsrvd: bound to ports
    ==> cpsrvd 11.56.0.8 started
    ==> cpsrvd: loading security policy....Done
    ==> cpsrvd: Setting up native SSL support ... Done
    ==> cpsrvd: transferred port bindings
    ==> cpsrvd: bound to ports
    [2016-04-26 17:50:51 +0100] info [xml-api] Using mirror '83.170.94.2' for host 'httpupdate.cpanel.net'.
     
    #1 dvk01uk, Apr 26, 2016
    Last edited by a moderator: Apr 26, 2016
  2. dvk01uk

    dvk01uk Registered

    Joined:
    Oct 20, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Don't worry. I have found the dormant services seem to have been enabled in 11.56 by default, whereas it was off previously
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Yes, as you mentioned, this is normal behavior that's associated with the dormant service functionality for cpsrvd in version 56. Per our documentation:

    This setting configures the system to unload idle services from memory after up to ten minutes of inactivity, and then loads listening devices that correspond to it. This setting reduces memory usage, but delays responses from dormant services. When you enable this setting for a service, that service will immediately enter dormant mode whenever you reboot your server or restart the service.

    Thus, this is why you see log output like this in /usr/local/cpanel/logs/error_log whenever the service exits out of dormant mode:

    Code:
    ==> cpsrvd 11.56.0.8 started
    ==> cpsrvd: loading security policy....Done
    ==> cpsrvd: Setting up native SSL support ... Done
    ==> cpsrvd: transferred port bindings
    ==> cpsrvd: bound to ports
    You can read more about this in the version 56 release notes:

    56 Release Notes - Documentation - cPanel Documentation

    Thank you.
     
Loading...

Share This Page