The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpu and memory full

Discussion in 'General Discussion' started by ph33r420, Jan 12, 2005.

  1. ph33r420

    ph33r420 Active Member

    Joined:
    Jan 8, 2005
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    after just a few hours of running, my cpu useage goes WAY up and my memory and swap fills up.

    i don't have the process and memory list right now because i just did a reboot. I'll post it up in a few hours.
     
  2. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    You could have anything from hardware issues, incorrect settings, compromised system.. the list goes on. I'd have someone with a decent working knowledge of your OS in use have a look and advise you further.
     
  3. ph33r420

    ph33r420 Active Member

    Joined:
    Jan 8, 2005
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    it's happening on my other servers also.. somethings using a lot of memory and processes are being killed because there is no more memory. which settings should i take a look at?



    User Domain %CPU %MEM Mysql Processes
    root 22.96 126.92 0.0
    Top Process %CPU 61.0 /bin/nice -5 -- nice
    Top Process %CPU 39.4 /usr/local/cpanel/whostmgr/bin/whostmgr doresetmysqlroot
    Top Process %CPU 30.2 /usr/local/cpanel/whostmgr/bin/whostmgr doresetmysqlroot
    nobody 3.07 0.26 0.0
    Top Process %CPU 32.1 /usr/local/apache/bin/httpd -DSSL
    Top Process %CPU 28.6 /usr/local/apache/bin/httpd -DSSL
    Top Process %CPU 27.3 /usr/local/apache/bin/httpd -DSSL
    mysql 1.27 2.00 0.0
    Top Process %CPU 28.9 /usr/libexec/mysqld --defaults-file/etc/my.cnf --basedir/usr --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/zeus.poweredbyxeon.com.pid --skip-locking
    Top Process %CPU 21.6 /usr/libexec/mysqld --defaults-file/etc/my.cnf --basedir/usr --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/zeus.poweredbyxeon.com.pid --skip-locking
    Top Process %CPU 20.4 /usr/libexec/mysqld --defaults-file/etc/my.cnf --basedir/usr --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/zeus.poweredbyxeon.com.pid --skip-locking
    mailman 1.08 2.73 0.0
    Top Process %CPU 17.2 /usr/bin/python2 -S /usr/local/cpanel/3rdparty/mailman/cron/nightly_gzip
    Top Process %CPU 15.2 /usr/bin/python2 -S /usr/local/cpanel/3rdparty/mailman/cron/nightly_gzip
    Top Process %CPU 2.8 /usr/bin/python2 /usr/local/cpanel/3rdparty/mailman/bin/qrunner --runnerIncomingRunner:0:1 -s


    that doesn't look good. :eek:
     
    #3 ph33r420, Jan 12, 2005
    Last edited: Jan 12, 2005
  4. s_2_s

    s_2_s Well-Known Member

    Joined:
    Aug 9, 2004
    Messages:
    215
    Likes Received:
    0
    Trophy Points:
    16
    same problem and cause of high load is httpd and mysql
     
  5. bigj

    bigj Well-Known Member

    Joined:
    Aug 9, 2003
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Tucson,AZ
    Hey s_2_s, I just replied to your other post but I figured I'd post here too for this other person. Since the load is on apache and mysql you may want to look at PHPbb/PHP.

    Do you have any customers using PHPbb? I had a problem on a non cpanel box that was being attacked due to an exploit of PHP < 4.3.10 and PHPbb < 2.0.11.

    Just throwing out some ideas. Hope that helps.

    bigj
     
  6. adtekinc

    adtekinc Registered

    Joined:
    Aug 18, 2002
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    same problem here. after update from R70 to R120 - RHE single processor.

    1200 misc mysql process in 2 hours running until the server dies. no domains on the box. fresh restore with old rhe and cpanel image - 2.4.21-4.0.1 and whm 8.6.?

    update everything and system goes wild with mysql process problem.

    updated kernal to 2.4.21-27.0.1.EL and same problem.

    hundreds of processes of each:

    /usr/local/cpanel/whostmgr/bin/whostmgr doresetmysqlroot

    /usr/bin/perl /scripts/restartsrv2 mysql

    /usr/bin/perl /scripts/restartsrv_mysql --check

    /usr/bin/perl /scripts/mysqlconnectioncheck

    [mysql <defunct>]

    hard and soft reboot do not fix the problem.

    downgraded to current 9.9.9-120 and still same problem.

    arrrrhghrhg !?!?!?!?!?!?!?!
     
  7. Donna

    Donna BANNED

    Joined:
    Feb 15, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Toronto, Canada
    No offense to the cpanel crew but atm nothing works, whatever they've done in the last 24 hours or so has completely screwed cpanel installs and apache recompiles. That goes for any version.

    To fix your problems do the following:

    /scripts/mysqlup

    Then reset the mysql root pass via WHM and reboot.
     
Loading...

Share This Page