The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CPU Skyrockets with Modules already loaded showing on Error Log

Discussion in 'General Discussion' started by chiefg, May 7, 2011.

  1. chiefg

    chiefg Registered

    Joined:
    May 7, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I'm running a php site running on php 5.3X and apache. New build off a good running site and php configured. My error log is getting bigger by the minute and CPU goes high when trying to access forums and my account in a nuke extreme site. /https://www.themotorpool.org/forum1/html/index.php

    These are the common errors showing up on the error log. I need some serious help while some good helping friends are trying to resolve this issue that have created the nuke extreme version platform.

    [07-May-2011 09:26:56] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home/chief/public_html/forum1/html/Zend/Cache/Core.php on line 357
    [07-May-2011 09:26:56] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home/chief/public_html/forum1/html/mainfile.php on line 1077
    [07-May-2011 09:28:34] PHP Warning: Module 'PDO' already loaded in Unknown on line 0
    [07-May-2011 09:28:34] PHP Warning: Module 'pdo_sqlite' already loaded in Unknown on line 0
    [07-May-2011 09:28:34] PHP Warning: Module 'SQLite' already loaded in Unknown on line 0
    [07-May-2011 09:28:34] PHP Warning: Module 'pdo_mysql' already loaded in Unknown on line 0
    [07-May-2011 09:28:34] PHP Warning: Module 'SourceGuardian' already loaded in Unknown on line 0

    Thanks,
    Ben
     
  2. jdilegge

    jdilegge Member

    Joined:
    Dec 17, 2010
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Boston, Ma
  3. chiefg

    chiefg Registered

    Joined:
    May 7, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    This is what I'm getting, but I'm not familiar on how and what to remove.

    ssh shot.jpg
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,696
    Likes Received:
    656
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    There two separate error messages in the error log snippet you provided.

    In regards to the first message in your error log:

    You can increase the "max_execution_time" parameter in the /usr/local/lib/php.ini file from 30 to the number your application requires (in seconds).

    As for the other message in the error log:

    To resolve this error message, you will need to remove the duplicate "extension=" entries in the /usr/local/lib/php.ini file. There should only be one entry for each extension, meaning "extension=" lines such as the following should only appear once:


    Code:
    extension=pdo.so
    extension=pdo_sqlite.so
    extension=sqlite.so
    extension=pdo_mysql.so
    You can edit the /usr/local/lib/php.ini file via the following command:

    Code:
    vi /usr/local/lib/php.ini
    Feel free to use the text editor of your choice if you are not comfortable using "vi" (e.g. nano or pico).

    Thank you :)
     
Loading...

Share This Page