The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

crazy cpu spikes all day long

Discussion in 'General Discussion' started by Secret Agent, Apr 12, 2005.

  1. Secret Agent

    Secret Agent Guest

    Ok, I've been getting crazy CPU load spikes on/off very often, all day long. From what I see, it looks like exim/spam assassin plus mysql "skip locking". I have posted some info below. Any help is truly appreciated.

    ps aux (when cpu load hit 22+) (note: cpu load spikes high rapidly, and decreases rapidly by itself, occassionally knocking apache down).

    (attached file for ps aux results)

    My info:
    :fail (Default catch-all/default address behavior for new accounts in tweak settings)
    MySQL 4.1
    Exim 4.50
    WHM / Cpanel 10.1 C23
    Spam Configuration (Maximum Children = 2, everything else blank)
    Mailscan (on)
    Exim Dictionary Attack ACL
    Dual Xeon / 2GB memory
     

    Attached Files:

    #1 Secret Agent, Apr 12, 2005
    Last edited by a moderator: Apr 12, 2005
  2. Secret Agent

    Secret Agent Guest

    Happened again, this time shot over 22 and taking a long time to go down, even after restarting Exim, cpanel.

    File attached for ps aux results.

    Looks like Horde is one issue

    Code:
    cpanel    9935 91.5  0.9 27408 19096 ?       R    18:48  22:51 /usr/local/cpanel/3rdparty/bin/php /usr/local/cpanel/base/horde/imp/message.php
    root     22552  4.3  3.2 70248 66884 ?       S    18:56   0:44 spamd child
    root     22553  2.2  1.2 28040 26112 ?       S    18:56   0:22 spamd child
    cpanel   32617 84.5  0.9 27408 19092 ?       R    19:01  10:03 /usr/local/cpanel/3rdparty/bin/php /usr/local/cpanel/base/horde/imp/message.php
    cpanel    3399 61.2  0.9 28520 19884 ?       R    19:09   2:36 /usr/local/cpanel/3rdparty/bin/php /usr/local/cpanel/base/horde/imp/message.php
    cpanel    6683  0.0  0.3  9440 8136 ?        S    19:10   0:00 webmaild - serving 206.48.0.60
    cpanel    6730 49.4  0.9 28568 20092 ?       R    19:10   1:41 /usr/local/cpanel/3rdparty/bin/php /usr/local/cpanel/base/horde/imp/message.php
    cpanel    7288  0.0  0.3  9440 8136 ?        S    19:10   0:00 webmaild - serving 206.48.0.60
    cpanel    7290 45.8  0.9 28164 19668 ?       R    19:10   1:31 /usr/local/cpanel/3rdparty/bin/php /usr/local/cpanel/base/horde/imp/message.php
    cpanel    7299  0.0  0.3  9440 8136 ?        S    19:10   0:00 webmaild - serving 206.48.0.60
    cpanel    7304 47.4  0.9 28568 19820 ?       R    19:10   1:34 /usr/local/cpanel/3rdparty/bin/php /usr/local/cpanel/base/horde/imp/message.php
    cpanel    7642  0.0  0.3  9440 8136 ?        S    19:10   0:00 webmaild - serving 206.48.0.60
    cpanel    7643 43.7  0.9 28580 20072 ?       R    19:10   1:24 /usr/local/cpanel/3rdparty/bin/php /usr/local/cpanel/base/horde/imp/message.php
    cpanel    8183 42.1  0.9 28620 19876 ?       R    19:12   0:16 /usr/local/cpanel/3rdparty/bin/php /usr/local/cpanel/base/horde/imp/message.php
    mailnull  8467  2.0  0.1  8036 3592 ?        S    19:13   0:00 /usr/sbin/exim -bd -q60m
    
    I ran /scripts/fullhordereset too

    Ran TOP

    Code:
      PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
     8183 cpanel    25   0 28488  19m 2732 R 48.9  1.0   3:46.40 php
    32617 cpanel    25   0 27408  18m 2724 R 45.9  0.9  13:31.43 php
    18483 nobody    25   0 28120  20m 4552 S 45.6  1.0   0:01.65 httpd
     7290 cpanel    25   0 28060  19m 2724 R 44.3  0.9   5:05.80 php
     7643 cpanel    25   0 28448  19m 2724 R 40.4  1.0   4:43.32 php
     3399 cpanel    25   0 28376  19m 2724 R 36.7  1.0   6:03.15 php
     9935 cpanel    25   0 27408  18m 2728 R 36.1  0.9  26:20.72 php
     7304 cpanel    25   0 28068  19m 2724 R 34.8  0.9   4:59.00 php
     6730 cpanel    25   0 28424  19m 2724 R 32.8  1.0   5:12.69 php
    
    Running PHP 4.3.11 too
     

    Attached Files:

    #2 Secret Agent, Apr 12, 2005
    Last edited by a moderator: Apr 12, 2005
  3. Spokuz

    Spokuz Well-Known Member
    PartnerNOC

    Joined:
    Apr 24, 2003
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lisbon - Portugal
    cPanel Access Level:
    Root Administrator
    I am having the same problem also. SOme users at EV1 are having this problem also. It seems that it is realted with exim
     
  4. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    It is very likely that the problem you guys experience is script related and not CPanel. You need to find out if there are scripts residing on your server used to send out massive number of email messages.

    You also need to apply/install the latest security patches and fixes protecting your server from hackers and viruses. PM me if you need help!
     
Loading...

Share This Page