The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

create account problem

Discussion in 'cPanel Developers' started by a-khamis, Jul 8, 2012.

  1. a-khamis

    a-khamis Registered

    Joined:
    Jul 5, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Reseller Owner
    hi ,

    i am using asp.net to call xml api and some functions works with me like version and accounts list but when i use

    ( createacct ) i get this response :

    <createacct>
    <result>
    <status>0</status>
    <statusmsg>$@ = Need either domain or domain_id in Domain-&gt;new at /var/www/lib/BannedList/Domain.pm line 28
    </statusmsg>
    </result>
    </createacct>

    on the other hand when i use the calling string by the browser it is work !!!!
    can any one tell me what i have to do to fix this problem .

    thank you

    best regards
     
  2. cPanelDavidN

    cPanelDavidN Integration Developer
    Staff Member

    Joined:
    Dec 17, 2009
    Messages:
    571
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    From that error message, it looks like there's some other software on your system that is prevent the request from succeeding. Looks like you'll need to find what's calling BannedList::Domain (or whatever it is)...cPanel doesn't ship that file.
    I'd look to see if there's a script hook or a standard hook; either might have been put there by some additional (WHM) Plugin.

    Regards,
    -DavidN
     
    #2 cPanelDavidN, Jul 9, 2012
    Last edited: Jul 9, 2012
Loading...

Share This Page