The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

create account, subdomain error

Discussion in 'General Discussion' started by manuxer, Sep 10, 2007.

  1. manuxer

    manuxer Active Member

    Joined:
    Aug 16, 2006
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    I run cpanel 11.11.0 E16942, wich i updated today. After i created an account, and trying to add a subdomain, the subdomain doesn't apper there. And in cpanel i get this error. After that the new domain created doesn't have an ip, and it is removed from httpd.conf:

    isdedicatedip() requires one argument (this probably means a domain is missing from httpd.conf) at /usr/local/cpanel/Cpanel/DIp.pm line 38
    Cpanel::DIp::isdedicatedip(undef) called at /usr/local/cpanel/Cpanel/ExpVar.pm line 185
    Cpanel::ExpVar::expvar('$hasdedicatedip') called at cpanel.pl line 1721
    main::execiftag('<cpanelif $hasdedicatedip>') called at cpanel.pl line 4392
    main::dotag(undef) called at cpanel.pl line 4281
    main::cpanel_parseblock('SCALAR(0x909bf88)') called at cpanel.pl line 4235
    main::cpanel_parse('GLOB(0x92e23fc)') called at cpanel.pl line 1077
    Carp::cluck('isdedicatedip() requires one argument (this probably means a dom...') called at /usr/local/cpanel/Cpanel/DIp.pm line 38
    Cpanel::DIp::isdedicatedip(undef) called at /usr/local/cpanel/Cpanel/ExpVar.pm line 185
    Cpanel::ExpVar::expvar('$hasdedicatedip') called at cpanel.pl line 1721
    main::execiftag('<cpanelif $hasdedicatedip>') called at cpanel.pl line 4392
    main::dotag(undef) called at cpanel.pl line 4281
    main::cpanel_parseblock('SCALAR(0x909bf88)') called at cpanel.pl line 4235
    main::cpanel_parse('GLOB(0x92e23fc)') called at cpanel.pl line 1077

    after that the site isn't working anymore.
    I cannot create another domains, and this is a major problem because i need to create at least 100 domains on this new server.
    This only happens for the newly created accounts.
     
    #1 manuxer, Sep 10, 2007
    Last edited: Sep 10, 2007
  2. maysoft

    maysoft Well-Known Member

    Joined:
    Nov 10, 2005
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    This will restore httpd.conf:

    /usr/local/cpanel/bin/userdata_update
    /scripts/rebuildhttpdconf
    /scripts/updateuserdomains
    service httpd restart


    Anyway, according to changelog, this appears to be fixed in Edge 16984 build.
     
Loading...

Share This Page