The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

create pureftpd user

Discussion in 'General Discussion' started by Lem0nHead, Mar 22, 2005.

  1. Lem0nHead

    Lem0nHead Well-Known Member

    Joined:
    Sep 2, 2003
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    hello

    i use cPanel and i've switched from proftpd to pureftpd, but i can't find how to create a pure-ftpd user without using cPanel

    i found that the /etc/proftpd/ dir is being modified (probably by cPanel), since some files last modified date is tomorrow... so maybe the pure-ftpd just import proftpd config?

    thanks
     
  2. Lem0nHead

    Lem0nHead Well-Known Member

    Joined:
    Sep 2, 2003
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    maybe i can use pure-pw useradd
    ?

    or it will conflict?
     
  3. grig

    grig Registered

    Joined:
    Jun 13, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    i've been working on this too.

    it seems that cpanel uses a hodge podge of pure-ftp and pro-ftp configs

    pure-ftp command line calls reveal that there is no password file for it so i doubt you can use it the way it was intended.


    i wish the cpanel ftp stuff was documented correctly somewhere

    i need to find the file that stores the passwords and directories so i can maintain them with my own scripts
     
    #3 grig, Jun 13, 2006
    Last edited: Jun 13, 2006
  4. grig

    grig Registered

    Joined:
    Jun 13, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    i case someones reading this:

    - I am using pure-ftp

    - in /etc/proftpd/passwd.vhosts you can find the users created but this doesn't seem to be controlling the behavior of ftp. i can remove a user from the passwd.vhosts and still log in with that user (after restarting the ftp services)

    - i've seen mention on these forums of the /etc/proftpd.conf file (mine is blank but there)

    WHERE ARE THE PASSWORDS AND PATHS DEFINED!?!? :eek:
     
    #4 grig, Jun 13, 2006
    Last edited: Jun 13, 2006
  5. grig

    grig Registered

    Joined:
    Jun 13, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    more hints?!?

    when running the scripts for restarting FTP, i noticed they're all the same command line script

     
    #5 grig, Jun 13, 2006
    Last edited: Jun 13, 2006
  6. grig

    grig Registered

    Joined:
    Jun 13, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    A solution!

    Yay!

    - root access via shell is needed (you will not see this file via FTP - since FTP is a jailed account)

    -the password file is in /etc/proftpd/ it will be the name of the virtual host

    - you will need to generate the right md5 password, this can be done with:
    /scripts/md5crypt

    - you will need to create your own folders

    - you don't need to restart any services after making the changes


    (I have no idea if cpanel will clobber this or not) for safety, update the other password file i mentioned above)

    hope this helps! Now I can write my own web app to create accounts and i no longer have to use public_html as the root (i can't believe this is the default!) :cool:

    p.s. always back up your files before you mess with them
     
    #6 grig, Jun 13, 2006
    Last edited: Jun 13, 2006
  7. justchil

    justchil Active Member

    Joined:
    Aug 1, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Have you tried setting up/down bandwith or changing the quota using this? I make changes yet nothing happens.

    [/etc/proftpd]# pure-pw show wvstreets -f chilz59

    Login : wvstreets
    Password : *******
    UID : 32003 (chilz59)
    GID : 504 (chilz59)
    Directory : /home/chilz59/public_html/wvstreets
    Full name : chilz59
    Download bandwidth : 5 Kb (enabled)
    Upload bandwidth : 5 Kb (enabled)
    Max files : 0 (unlimited)
    Max size : 0 Mb (unlimited)
    Ratio : 0:0 (unlimited:unlimited)
    Allowed local IPs :
    Denied local IPs :
    Allowed client IPs :
    Denied client IPs :
    Time restrictions : 0000-0000 (unlimited)
    Max sim sessions : 0 (unlimited)

    I used:

    pure-pw usermod wvstreets -t 5 -T 5 -f chilz59


    Yet nothing happens.

    Here is the line from the "chilz59" file.

    wvstreets:******:32003:504:chilz59:/home/chilz59/public_html/wvstreets:5120:5120::::::::::
     
  8. justchil

    justchil Active Member

    Joined:
    Aug 1, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Ok scratch all that. I'm going to setup another standalone ftp that will work properly :)
     
Loading...

Share This Page