The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Crippled Autofil on Login Page !

Discussion in 'Security' started by fookraa, Apr 5, 2012.

  1. fookraa

    fookraa Registered

    Joined:
    Jun 21, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I am using Google Chrome, and i have saved my cPanel passwords within the chrome's auto-fill. :D

    Earlier, the moment I used to navigate to "" https://example.com:2083 "" my username and password were already filled by auto-fill and I were to simply press "enter" and login. :)

    However since my hosting provider has updated the cpanel to the latest version,
    I am unable to use this auto-fill password functionality on any browser. :mad:

    Thu functionality of a browser's auto-fill & auto-save password has been totally lost on this new login page. :confused:

    PS:
    I am referring to the new blue-color schemed login page.
    View attachment 10121
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    There's a new setting to disable this if you wish:
    WHM > Server Configuration > Tweak Settings, Security tab

    Allow autocomplete in login screens.
     
  3. MACscr

    MACscr Well-Known Member

    Joined:
    Sep 30, 2003
    Messages:
    190
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    And of course cpanel felt the need to have every new feature on as usual......
     
  4. MACscr

    MACscr Well-Known Member

    Joined:
    Sep 30, 2003
    Messages:
    190
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Also, is their a cli option to disable this? Need to be able to mass change it on all our servers.
     
  5. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello,

    The entry is the following in /var/cpanel/cpanel.config file:

    Code:
    allow_login_autocomplete=1
    The 1 means On and 0 means Off. If you change the entry, please run the following:

    Code:
    /usr/local/cpanel/whostmgr/bin/whostmgr2 --updatetweaksettings
    Thanks!
     
  6. JohnnyBob

    JohnnyBob Active Member

    Joined:
    Oct 13, 2006
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    I have a similar problem as the original poster...

    My Google Chrome 23 browser won't remember the cpanel login info and fill it in automatically. I must copy & paste it each time I login which is a royal PITA because I access cpanel frequently. I have the Autocomplete = on extension but that doesn't make any difference. My Firefox 18 browser works fine in that regard. Why not Chrome 23?

    You mention some solutions involving WHM, which I don't have. If I need WHM, how would I get it?


    cpanel-chrome2.png
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  8. JohnnyBob

    JohnnyBob Active Member

    Joined:
    Oct 13, 2006
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    The javascript trick worked. 1) Turn off javascript in Chrome. 2) Login to cpanel, save password when prompted, logout. 3) Turn on javascript in Chrome. Then it remembers and autofills the username and password box when logging in again in future. I've tried it several times. That's purely magic, not something anyone could figure out on their own.

    [I didn't receive a WHM login username/password when I purchased a hosting service for my domain, so I guess I don't have it. I can ask them but I probably just have cpanel.]

    I don't know if the following is a cpanel or Chrome problem. Do you know how to disable the SSL security certificate warning (or enter an exception in Chrome) when logging into cpanel? Firefox allows entering an exception so I never see this nag again, but I can't figure out how to get rid of it in Chrome...

    cpanel-ssl.png

    Thanks very much!
     
    #8 JohnnyBob, Jan 14, 2013
    Last edited: Jan 14, 2013
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You should speak with your Hosting Provider about this, there are Redirection settings that should be helpful to you located here:
    WHM » Server Configuration » Tweak Settings, Redirection tab;

    Redirection tab in Tweak Settings - cPanel Documentation

    In a nutshell, if your domain does not have its own dedicated IP and certificate, which seems to be the case for your domain, changing those Redirection settings to send you to the proper URL on the server that does, is the way to go.

    yourdomain.com:2083 has no cert.
    host.hisdomain.com:2083 does have a cert.
     

Share This Page