SOLVED [Critical] hostname.tld has refused the connection.

Operating System & Version
CentOS 7

nettopia

Registered
Sep 30, 2021
4
1
1
the netherlands
cPanel Access Level
Root Administrator
Since today my WHM panel and cPanel can no longer be reached.
Every time I try to reach the pages I get the error message cp.nettopia.nl has refused the connection.
This problem occurs on different IP addresses and is therefore not an IP bound problem.

Yesterday I was able to visit the pages and now I can't.
There is no way I can reach the pages.

I have disabled all firewalls and protections but the problem persists.
The system has also been rebooted.

I am aware of the current issues with the AutoSSL and have applied the workaround to see if this is the issue. However, I still can't get to it.

Does anyone know what could be causing this?

All websites are still running except for the hostname and ports.
 

kodeslogic

Well-Known Member
Apr 26, 2020
334
128
118
IN
cPanel Access Level
Root Administrator
Have you tried restarting the cPanel service?

Code:
#systemctl restart cpanel
If restarting the cpanel service does not help then share the output of the below commands

Code:
#systemctl status firewalld
#csf -s
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,519
1,027
313
cPanel Access Level
Root Administrator
As usual, good advice from @kodeslogic - I'd add that a quick check of the ports themselves on the server would tell you if the service is listening properly:

Code:
netstat -lpn | grep 208
which should give you a few lines of output indicating a service is listening on all the cPanel ports.

If the service seems to be running normally, a telnet test to the cPanel and WHM ports from your specific location would be helpful to see if the ports themselves are working.
 

nettopia

Registered
Sep 30, 2021
4
1
1
the netherlands
cPanel Access Level
Root Administrator
Have you tried restarting the cPanel service?

Code:
#systemctl restart cpanel
If restarting the cpanel service does not help then share the output of the below commands

Code:
#systemctl status firewalld
#csf -s
Hello, thank you for your reply.
Here is a screen of the output of both commands.

1633130092591.png

I turned off the firewall, connection still refused.
 

nettopia

Registered
Sep 30, 2021
4
1
1
the netherlands
cPanel Access Level
Root Administrator
As usual, good advice from @kodeslogic - I'd add that a quick check of the ports themselves on the server would tell you if the service is listening properly:

Code:
netstat -lpn | grep 208
which should give you a few lines of output indicating a service is listening on all the cPanel ports.

If the service seems to be running normally, a telnet test to the cPanel and WHM ports from your specific location would be helpful to see if the ports themselves are working.
Hello, thank you for your reply!
Here is a screenshot of the output
1633130194648.png
Shouldn't these ports be connected to the ip address of the server instead of 0.0.0.0 ?
 

nettopia

Registered
Sep 30, 2021
4
1
1
the netherlands
cPanel Access Level
Root Administrator
This problem has been solved.
Somehow the IP address for the hostname was changed at the hosting provider a long time ago to an unknown ip address.
And it always worked until a few days ago it randomly stopped working.
 
  • Like
Reactions: cPRex