The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Critical: remote code execution in ClamAV

Discussion in 'cPanel Developers' started by qwerty, Nov 4, 2005.

  1. qwerty

    qwerty Well-Known Member

    Joined:
    Jan 21, 2003
    Messages:
    213
    Likes Received:
    0
    Trophy Points:
    16
  2. arhs

    arhs Well-Known Member

    Joined:
    Jul 4, 2003
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    16
  3. PvUtrix

    PvUtrix Well-Known Member

    Joined:
    Mar 12, 2005
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Ekaterinburg - Russia
    cPanel Access Level:
    Root Administrator
    let's hope the update doesn't take long to be available through cpanel...
     
  4. MattGetWeb

    MattGetWeb Well-Known Member

    Joined:
    Aug 4, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Why does WHM report that I have the latest version (0.87-1.0) installed, when I don't?

    # /usr/sbin/clamd -V
    ClamAV 0.87/1166/Tue Nov 8 05:01:45 2005

    I even tried uninstalling/re-installing clamavconnector, but WHM just downloads 0.87.
     
  5. qwerty

    qwerty Well-Known Member

    Joined:
    Jan 21, 2003
    Messages:
    213
    Likes Received:
    0
    Trophy Points:
    16
    Because 0.87.1 and 0.87-1.0 are not one and the same thing, unless you're dyslexic :)

    The 1.0 after the dash simply refers to the internal cpanel installer version. ie. it's ClamAV 0.87 cpanel installer version 1.0
     
  6. MattGetWeb

    MattGetWeb Well-Known Member

    Joined:
    Aug 4, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Doh! Thanks! :eek:
     
  7. qwerty

    qwerty Well-Known Member

    Joined:
    Jan 21, 2003
    Messages:
    213
    Likes Received:
    0
    Trophy Points:
    16
    The clamavconnector module has now been updated to include clamav 0.87.1

    Simply uninstall and reinstall from WHM's modules section.

    Even though the version number in WHM doesn't look right, it does install 0.87.1 now.
     
Loading...

Share This Page