The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cron fails but browser execution works

Discussion in 'General Discussion' started by blissend, Feb 12, 2010.

  1. blissend

    blissend Member

    Joined:
    May 16, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    This is probably a shot in the dark here but my cronjob was working until today. It's just a php script I made in a protected folder. It works great if I run it directly from the browser window, but the old cron tasks fails to execute anymore. Here's what I checked for and tried...


    • No error_log file. Usually it generates this in the folder if something goes wrong.
    • /var/log/cron shows execution but nothing else.
    • Tried restarting the services. No Luck
    • Tried doing a graceful restart on server. No Luck.
    • Tried execution as root and get a File Missing message but thats it. Doesn't say what file it was searching for oddly.

    Is there anything else I should try? Any more info someone would need? Pulling my hair out on the weirdness of this to suddenly stop working. No cpanel updates happened on it recently as far as I know.

    The cronjob command executed every minute...
    php /home/ihavecnb/public_html/power/runcron.php
    which was this before but I wanted to see any error messages...
    php /home/ihavecnb/public_html/power/runcron.php >/dev/null 2>&1

    Hopefully someone out there might have some insight 8)
     
    #1 blissend, Feb 12, 2010
    Last edited: Feb 12, 2010
  2. blissend

    blissend Member

    Joined:
    May 16, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Nevermind. I figured it out... too weird to explain why it works in the browser and not via cronjob.
     
Loading...

Share This Page