The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cron jobs don't work :(

Discussion in 'General Discussion' started by Radio_Head, Sep 4, 2002.

  1. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    Hello

    I tried to insert these cronjobs via Cpanel

    * * * * * GET http://www.domain.com/cgi-bin/cron.pl & /dev/null

    it doesn't work


    * * * * * perl /home/user/public_html/cgi-bin/cron.pl

    it doesn't work

    What I have to do to make cronjobs running ?


    (1) If I execute GET http://www.domain.com/cgi-bin/cron.pl & /dev/null from command line it works
    2) cron.pl is ch-moded 755)
    3) I am on redhat 7.2
    )


    Thank you !
     
  2. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    it could be a permission problem on cgi-bin ?
     
  3. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    Anyone can help ?
     
  4. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    OK , the solution was

    /etc/rc.d/init.d/crond restart


    now cron works fine :p
     
Loading...

Share This Page