The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cron jobs not showing up

Discussion in 'General Discussion' started by matins007, Jan 15, 2009.

  1. matins007

    matins007 Member

    Joined:
    Jan 15, 2009
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    When creating cron jobs in my cPanel it gives me no errors and tells me that the crons jobs have been updated. But when I look back I don't see any cron jobs.

    Any idea what could be causing this and where to look?

    Thanks

    I already posted this in the new user questions sections, but thought it would be more appropriate here.
     
  2. matins007

    matins007 Member

    Joined:
    Jan 15, 2009
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Problem solved

    If you get this problem you will probably notice that there is a "/usr/bin/crontab permissions are wrong. Please set to 4755" error message in the cron jobs cpanel landing page.

    To fix this you will need to change the permission on the folder in SSH with the following line

    chmod 4755 /usr/bin/crontab

    Note that for this to work you will need to have a root access permissions to the server.

    Hope this helps someone
     
  3. soundguy

    soundguy Well-Known Member
    PartnerNOC

    Joined:
    Oct 29, 2003
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    seattle
    Just discovered this problem myself on a new 64-bit CentOS 5.2 installation. The mystery here is WHY are the permissions wrong on a brand new server?
     
  4. Dawzz

    Dawzz Member

    Joined:
    Nov 11, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    myself also fresh intall
     
  5. stupidnic

    stupidnic Registered

    Joined:
    Jan 4, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I have experienced the same problem on a fresh CentOS 5.2 install.

    I believe that cPanel had been relying on default permissions of the file from the underlying OS, but that has changed in 5.2.

    I just checked a CentOS 4.7 server and it has the 4755 permissions set, but another fresh install of CentOS 5.2 has it as just 0755.

    I can confirm that setting the permissions to 4755 on this file corrects the OP problem.
     
Loading...

Share This Page