manChicago

Registered
Apr 15, 2006
3
0
151
Ok First the apology- I KNOW this must have been dealt with elsewhere but I cant find it in google or on the search forums button because the words are just so generic...

Users cron dosnt seem to work....

Now, to get more specific - when adding a cron to the system through the Cpanel interface, it says its added, but dosn't seem to do anything. Going back into standard or advanced shows no crons there - just the add new crons part.

Im sure the root crons (ie into shell, sudo su, crontab -e ) are there and working fine, but I dont think any one elses crons can be added (and :. not running).

What stupidly simple thing have I done wrong?

Thanks
JT
 

manChicago

Registered
Apr 15, 2006
3
0
151
Hi,

In the /var/spool/cron there are only files for root and mailman - not for any of my users.

the /var/log/cron file shows no problems with any running crons.

I am of the belief that the web interface is not actually adding the commands to the cron system :S

The permissions on the spool directory are as follows:

drwx------ 2 root root 4096 Apr 15 15:41 cron/

are these sufficient? I have tried setting those to higher privildges but nothing changes when i go through the add cron procedure, (no files added, no crons appearing on the cron screen)

Thanks
JT
 

bijo

Well-Known Member
Aug 21, 2004
474
0
166
India
Hello,

Did you chack the cpanel error log?. If not try to add a cron job to a particular user through cpanel and check the cpanel error log (tail -f /usr/local/cpanel/logs/error_log). It will help you to find out the problem.
 

manChicago

Registered
Apr 15, 2006
3
0
151
Thanks and now fixed... sort of...

seteuid: Operation not permitted

Ahaar! Google now lets me getsomewhere- I tried adding a cron.allow file in /etc/exec but that didnt help, so looking on found me this:

https://listman.redhat.com/archives/redhat-install-list/2001-April/msg00535.html

[email protected] [/usr/bin]# ls -la crontab
-rwxr-xr-x 1 root root 114765 Jun 6 2003 crontab

[email protected] [/usr/bin]# chmod 4755 crontab
[email protected] [/usr/bin]# ls -la crontab
-rwsr-xr-x 1 root root 114765 Jun 6 2003 crontab*

Now I wonder why that was not right? (but it works now, thanks)

JT