The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cron probs... likely summat simple...

Discussion in 'General Discussion' started by [O-CuK]Marci, May 9, 2007.

  1. [O-CuK]Marci

    [O-CuK]Marci Active Member

    Joined:
    Jun 3, 2004
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Having some issues with a cronjob that formerly ran perfectly, and now appear to have caused itself upset...

    $HOME/public_html/rss/index-xml.php - this regenerates my RSS feed from my database, and runs at 1 minute past the hour, and simply uses fpopen to write to $HOME/public_html/rss/index.xml

    Cron kindly emails me:
    /home/tmc/public_html/rss/index-xml.php: not found

    The file is most definitely found, and have tried it with permissions at 777, 755, 775. Cronjob is being run as the correct user, and cronjob was put in place thru cPanel... file in question is owned by the correct user. The file can be found publicly via webbrowser (http://www.themusiccollective.co.uk/rss/index-xml.php) and runs fine if initiated this way, and correctly updates http://www.themusiccollective.co.uk/rss/index.xml (removes previous gigs so that it only lists gigs from todays date onwards). Any suggestions?
     
  2. [O-CuK]Marci

    [O-CuK]Marci Active Member

    Joined:
    Jun 3, 2004
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Ignore me - I'm officially a tit!

    Reuploaded file as ASCII and works fine now... WS_FTP was set to "Auto" :(
     
Loading...

Share This Page