The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cron <root@> /usr/bin/freshclam --quiet --no-warnings

Discussion in 'General Discussion' started by RBRBRB, May 14, 2009.

  1. RBRBRB

    RBRBRB Member

    Joined:
    Oct 16, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    ERROR: cdiff_apply: lseek(desc, -350, SEEK_END) failed
    ERROR: getpatch: Can't apply patch

    how to solve this problem, please help

    Brian
     
  2. rone

    rone Well-Known Member

    Joined:
    Jan 14, 2007
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    The Netherlands
    cPanel Access Level:
    Root Administrator
    I received the same error today.
     
  3. yayyo

    yayyo Well-Known Member

    Joined:
    Jul 10, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    London, UK
    cPanel Access Level:
    Root Administrator
    -ditto-

    cPanel 11.24.4-R35075 - WHM 11.24.2 - X 3.9

    CENTOS 5.3 i686 standard
     
  4. bhd

    bhd Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    JNB ZA
    cPanel Access Level:
    Root Administrator
    here too. On all but one server. All CentOS.
     
  5. webstyler

    webstyler Well-Known Member

    Joined:
    Nov 20, 2003
    Messages:
    432
    Likes Received:
    0
    Trophy Points:
    16
    same problem here

    :/
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Try re-installing ClamAV by unchecking ClamAV Connector in the WHM Plug-ins screen and then clicking save, going back to the screen and then re-checking ClamAV Connector.
     
  7. yayyo

    yayyo Well-Known Member

    Joined:
    Jul 10, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    London, UK
    cPanel Access Level:
    Root Administrator
    Thanks David, a manual update seems to run ok:
    But I don't see the option you mention in WHM? All I see under "Plugins" is:-

    * Addon Script Manager
    * Configure ClamAV Scanner
    * ConfigServer Mail Manage
    * ConfigServer Mail Queues
    * Configure cPanel Cron Times
    * ConfigServer Security&Firewall
    * Fantastico De Luxe WHM Admin
    * Mod Security
    * WHM Xtra

    None of which have an option to "Uncheck ClamAV Connector" - What am I missing?
     
  8. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I was referring to WHM -> cPanel -> Manage Plugins.
     
  9. yayyo

    yayyo Well-Known Member

    Joined:
    Jul 10, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    London, UK
    cPanel Access Level:
    Root Administrator
    :eek: Thanks again David. Got it now. That, for me, as a dedicated host user rather than a reseller was one of those "fire and forget" areas of WHM :)

    I now return you to the peer-to-peer support we usually get from these forums ;)

    If you desire technical assistance from our staff, please let cPanel technical analysts take a look at your server for you. You can do this by submitting a support ticket at http://tickets.cPanel.net/submit
     
  10. darklord1

    darklord1 Well-Known Member

    Joined:
    Jul 8, 2006
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I thought this might help, for those who are still seeing this issue.

    I ran into this issue and proceeded to figure a fix.

    I went into ssh and did the following:

    cd /usr/local/cpanel/modules-install/

    ls -al|grep clam

    cd clamavconnector-Linux-x86_64 #(your's may be different)

    sh install

    ls -al /usr/bin/freshclam

    When I ran the installer from command line, I noticed it took quite a bit longer to run then it did in whm, and everything was installed correctly.

    It's a bit early, so I've not investigated any further, but my hunch is that is has something to do with the path difference in shell over whm.

    Hope this helps someone else too.
     
  11. mohit

    mohit Well-Known Member

    Joined:
    Jul 12, 2005
    Messages:
    553
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sticky On Internet
    Having same issue on a brand new dedicated server 64 bit centOS

    cPanel 11.25.0-R46156 - WHM 11.25.0 - X 3.9
    CENTOS 5.5 x86_64 standard


    darklord1, Thanks for sharing the solution I am going to try this now.
     
  12. santrix

    santrix Well-Known Member

    Joined:
    Nov 30, 2008
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    18
    I am running 64bit Centos and after adding ClamAV for the first time and assuming it was all ok, I found I got an email the next morning with:

    /bin/sh: /usr/bin/freshclam: No such file or directory

    I then found that clamd and freshclam simply weren't installed. I tried this solution this morning, and it appears to have worked fine. As you say, the build process takes much longer (almost 4 times as long), and it results in

    # whereis clamd
    clamd: /usr/sbin/clamd /etc/clamd.conf /usr/share/man/man8/clamd.8

    Whereas before the only thing there was the clamd.conf file. It has integrated

    av_scanner = clamd:/var/clamd

    into the exim.conf and everything seems fine and dandy. Freshclam works ok now.

    Hope cPanel can fix this or confirm this workaround is sound. :confused:
     
Loading...

Share This Page