The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cron /scripts/upcp - Unable to locate working expect!

Discussion in 'General Discussion' started by Bdzzld, Nov 13, 2005.

  1. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Hello,

    The first lines in the Cron /scripts/upcp contain the following :

    Code:
    Unable to locate working expect! Please check your installation.
    Found hostname to be server.domain.xxx, which resolves to 1.2.3.4
    Hostname Virtual Host is already setup
    PHP version file is up to date
    Ftp Quota Check v1.0
    Cpanel updates are coming from layer2.cpanel.net
    Locking password for user daemon.
    passwd: Success
    Send Disk Warning
    Buggy hardware detected!!
    Skipping Disk Integrity Check
    The following controllers have problems with S.M.A.R.T:
    3ware PERCRAID 3w-xxx Promise and FastTrack
    Ftp Setup Script Version 6.0
    ...
    
    1) To what is the first line (Unable to locate working expect! Please check your installation.) refering? That line started to appear after the hostname needed to be changed, as far as I know...

    2) Why is cPanel trying to check the 3Ware Escalade 8006-2 S-ATA RAID-1 controller for errors or saying it's buggy because it does not have S.M.A.R.T technology? S-ATA controllers do not have S.M.A.R.T technology, only E-IDE.

    Thanks.
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Do the following:

    touch /var/cpanel/disablesmartcheck

    This will skip the hardware check and won't cause the server to crash.

    If that doesn't work, removed this line from /scripts/upcp script:
    system("/scripts/smartcheck");

    Then, run the command /scripts/upcp --force
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    AS for expect itself, you need to install that using your OS update tool, you don't mention wnat your OS is, but you would usually use (for Linux) either:

    up2date -ui expect

    or

    yum install expect
     
  4. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Transaction Check Error

    Hi,

    That indeed solved the problems :) Thanks...

    Every day the e-mails also contains the following :

    Code:
    ...
    Transaction Check Error:   file /usr/share/man/man5/fonts-conf.5.gz from install of fontconfig-2.2.3-7 conflicts with file from package fontconfig-2.2.3-7
    Setting up Install Process
    Setting up repositories
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished
    Parsing package install arguments
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Package gd-progs.x86_64 0:2.0.28-4 set to be updated
    ---> Package gd.x86_64 0:2.0.28-4 set to be updated
    ---> Package gd-devel.x86_64 0:2.0.28-4 set to be updated
    ---> Package bind-devel.x86_64 20:9.2.4-2 set to be updated
    ---> Package sharutils.x86_64 0:4.2.1-22.2 set to be updated
    ---> Package gd.i386 0:2.0.28-4 set to be updated
    --> Running transaction check
    --> Processing Dependency: libX11.so.6 for package: gd
    --> Processing Dependency: libjpeg.so.62 for package: gd
    --> Processing Dependency: libXpm.so.4 for package: gd
    --> Processing Dependency: libpng12.so.0 for package: gd
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package xorg-x11-libs.i386 0:6.8.2-1.EL.13.20 set to be updated
    ---> Package libjpeg.i386 0:6b-33 set to be updated
    ---> Package libpng.i386 2:1.2.7-1 set to be updated
    --> Running transaction check
    --> Processing Dependency: libexpat.so.0 for package: xorg-x11-libs
    --> Processing Dependency: libGL.so.1 for package: xorg-x11-libs
    --> Processing Dependency: libfontconfig.so.1 for package: xorg-x11-libs
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package expat.i386 0:1.95.7-4 set to be updated
    ---> Package xorg-x11-Mesa-libGL.i386 0:6.8.2-1.EL.13.20 set to be updated
    ---> Package fontconfig.i386 0:2.2.3-7 set to be updated
    --> Running transaction check
    
    
    Dependencies Resolved
    ...
    
    Every day it tries to correct it, but that's unsuccessfull...

    FYI : Server is running CentOS 4.2 x86_64.

    Any ideas how to resolve this issue?
    Thanks.
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Try:

    rpm -e --justdb fontconfig fontconfig-devel --nodeps
    yum install fontconfig fontconfig-devel
     
Loading...

Share This Page