The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Crond Not Working

Discussion in 'General Discussion' started by Millar, Oct 9, 2007.

  1. Millar

    Millar Active Member

    Joined:
    Dec 23, 2006
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Hello everyone!

    My server was working fine and then all of a sudden (I didn't even change anything) my cronjobs packed in.

    My site relies heveily on frequent cronjobs and I have done all I can to find a solution but none will work.

    When I check the Crond logs, it shows that the command has run but it hasn't actually run. Then when I run the exact command in shell it works just fine.

    So I have no idea what is wrong and would greatly appreciate any assistance you can offer!

    Also I have set my email for the cron output to be sent to which normally works whether or not the command works. No emails have been received though.

    I have also tried restarted crond with no luck. :(

    Thanks in advanced,
    Millbob.
     
    #1 Millar, Oct 9, 2007
    Last edited: Oct 9, 2007
  2. Millar

    Millar Active Member

    Joined:
    Dec 23, 2006
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    I am still looking for a solution. :(

    I have tried all I can with no luck.
     
  3. rexrjacob

    rexrjacob Member

    Joined:
    Mar 25, 2006
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    If you have shell access, and if restarting crond service is fixing the issue, then you may add the following given line in the crontab

    server[~]# crontab -e

    */5 * * * * /etc/rc.d/init.d/crond restart
     
  4. savitha

    savitha Member

    Joined:
    Jan 4, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Cochin
    This is not at all good to setup a cronjob to restart the service every 5 sec.

    Check the log file /var/log/cron for more detailed error and fix that.
     
Loading...

Share This Page