The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cronjob problem

Discussion in 'General Discussion' started by Secret Agent, Dec 27, 2005.

  1. Secret Agent

    Secret Agent Guest

    cron problem:

    /bin/sh: /usr/bin/wget: Permission denied

    (on reseller account).

    Using CURRENT version of cpanel. What could cause this? I know wget is enabled on the server so that should not be the case. The cron of course is setup via the account's cpanel
     
  2. sunyl

    sunyl Active Member

    Joined:
    Oct 12, 2004
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Try to set 755 permission to /usr/bin/wget and see if it works :)

    Sunyl...
     
  3. Secret Agent

    Secret Agent Guest

    The client is a reseller client not a dedicated server client. I have not recieved any other complaints about cron jobs from the other share reseller clients or shared clients on the server yet.

    Anyone else have any suggestions?
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    As sunyl said, you need to check the file permissions on /usr/bin/wget as that's where the error indicates the problem is.
     
  5. Silver_2000

    Silver_2000 Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    338
    Likes Received:
    1
    Trophy Points:
    18
    I just started getting "/bin/sh: /usr/bin/wget: Permission denied"

    The note here should have fixed it - I would love to know what changed wget to having the most restrictive permissions of ay file in that folder ...
     
  6. gregb49

    gregb49 Member

    Joined:
    Jul 30, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Do you have to use wget? It is not enabled on my cPanel. After much trial and error, this worked for me. (This is for a Post_Man plugin under Nucleus)
    Code:
    php /home/digital/public_html/muppets/action.php action=plugin name=PostMan
    I had been trying
    Code:
    php /home/digital/public_html/muppets/action.php?action=plugin&name=PostMan 
    where digital is my account name and muppets is a sub folder in the home directory (this is just a test site)

    I don't know why this worked. Remove "?" and "&" and replace with a SPACE, but it did.

    Maybe in your case, you could put this in your cPanel Cron Jobs
    Code:
    php /home/youraccountname/mentor/admin/cron.php
    But I am not a php coder. Greg
     
Loading...

Share This Page