The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cronjobs aren't being added

Discussion in 'CloudLinux' started by uadm, Sep 30, 2015.

  1. uadm

    uadm Well-Known Member

    Joined:
    May 19, 2003
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    on one of our server cronjobs are not being added.

    Users go to cpanel -> cron jobs
    add the time and command and press add new cronjob. It sais cronjob is added but then we don't see the job in the cron list of cpanel and nither on the server in /var/spool/cron/USER

    This is happening to all users.
     
  2. uadm

    uadm Well-Known Member

    Joined:
    May 19, 2003
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    a little bit more info:
    shell is /usr/local/cpanel/bin/noshell
    there's no cron also in ~user/.cagefs/var/spool/cron
     
  3. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    275
    Likes Received:
    31
    Trophy Points:
    28
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    Code:
    # tail - f /usr/local/cpanel/logs/error_log
    Run that, try adding a new cron and see if there is any output.
     
  4. uadm

    uadm Well-Known Member

    Joined:
    May 19, 2003
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    Doesn't give any output or error.
     
  5. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    275
    Likes Received:
    31
    Trophy Points:
    28
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    Does it work if you disable cagefs
     
  6. uadm

    uadm Well-Known Member

    Joined:
    May 19, 2003
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    no. we tried but doesn't work.
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can try running the following command:

    Code:
    cagefsctl –force-update
    Also, are any of the accounts assigned shell access or jailed shell access?

    Thank you.
     
  8. uadm

    uadm Well-Known Member

    Joined:
    May 19, 2003
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    running cafefsctl --force-update didn't help.
    all the users have /usr/local/cpanel/bin/noshell
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  10. uadm

    uadm Well-Known Member

    Joined:
    May 19, 2003
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    changing to jailshell -> trying to add cron = doesn't work
    reverting to noshell -> trying to add cron = doesn't work
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  12. uadm

    uadm Well-Known Member

    Joined:
    May 19, 2003
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    ticket 7229695
     
  13. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    To update, internal case CPANEL-389 addresses an issue where if an account is set to "Jailshell" or "NoShell" in WHM, you are not able to create a cron job for that user. The workaround is to manually create the touch file for the account username in the /var/spool/cron/ directory.

    Thank you.
     

Share This Page