Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

csf Memory Limiter

Discussion in 'General Discussion' started by jimmy1987, May 12, 2008.

  1. jimmy1987

    jimmy1987 Member

    Joined:
    Feb 27, 2008
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    51
    How do i get rid of this very annoying function?

    Don't give me the usual but it is safe for your server story, because that function is a pain in the ass.
    It gives me emails with resource limits even when browsing cpanel.

    So how do i turn it off?

    To show what i mean:

    Time: Mon May 12 23:03:09 2008
    Account: xxxxx
    Resource: Virtual Memory Size
    Exceeded: 124 > 100 (MB)
    Executable: /usr/local/cpanel/cpanel
    Command Line: /usr/local/cpanel/cpanel ./frontend/x3/passwd/changepass.html
    PID: 17547
    Killed: No
     
    #1 jimmy1987, May 12, 2008
    Last edited: May 12, 2008
  2. viraj

    viraj Well-Known Member

    Joined:
    Sep 28, 2006
    Messages:
    209
    Likes Received:
    1
    Trophy Points:
    166
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Do you have CSF/LFD installed on your system ? If yes you can disable the notifications from the process section.

    You can also remove the Apache memory & CPU limiters by commenting the following entries from the httpd.conf file :

     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #2 viraj, May 12, 2008
    Last edited: May 12, 2008
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,339
    Likes Received:
    402
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Modify Apache Memory Usage under the Security section of WHM left menu. Might want to click that link and have it set for you.


     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    7
    Trophy Points:
    318
    Location:
    back woods of NC, USA
    i am thinking that the forums are all screwed up. His post has nothing to do with apache but yet the title does.

    the LFD warning email's come from when a user logs into cPanel and makes changes. I get them all the time. You could erase apache from the servers and you would still get these warnings.

    I believe there are some exclusions list in the csf configuration settings. check there :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Just add:

    exe:/usr/local/cpanel/cpanel

    to /etc/csf/csf.pignore and then restart lfd:

    service lfd restart

    Or increase the memory limit in csf.conf
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #5 chirpy, May 14, 2008
    Last edited: May 14, 2008
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice