CSF smpt_block + CURRENT_14823 = can't send from Horde ?

velda

Well-Known Member
Aug 24, 2005
54
0
156
Utah
Hi,

I've got one server with a problem sending mail today. We have CSF (2.77), Horde, and Cpanel 11.6.0-CURRENT_14823 .

On sending mail, we get this:
There was an error sending your message: Failed to connect to localhost:25 [SMTP: Failed to connect socket: Connection refused (code: -1, response: )]

I immediately tried setting smtp_block to OFF (0) in CSF, and sure enough, the mail goes through that way. However, I have several other servers that are running different versions of cpanel, same version of CSF, and the smpt_block ON (1) -- and they're able to send mail from horde without a problem.

I can work around the issue for the moment but am wondering if anyone else has this issue today and what the best fix would be. Thanks in advance for any ideas :)


Velda Christensen
Hands-On Web Hosting
 

Bailey

Well-Known Member
Aug 12, 2001
120
1
318
Wisconsin
If you do a search on ConfigServer's forums, you'll find this is a known issue. According to Chirpy, Horde shouldn't be sending mail using smtp, it should only by using sendmail. The solution is to do an under-the-hood modification to Horde (which personally, I wouldn't do, but that's just me).

I think there is a conflict here that ConfigServer and cPanel need to work out. Obviously one camp thinks Horde should be run one way, and the other camp thinks it should be run another way.

And I'm not saying one is right and one is wrong. I don't know the first thing about it, I just recognize there is a conflict in opinion there. I don't like to intentionally walk around on minefields ;) LOL, so I hope that the two parties are able to come to common ground so that user experience remains smooth.

$0.02.

:D Bailey
 
Last edited:

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
33
473
Go on, have a guess
Just make sure you're running the latest version of csf which should cater for the change cPanel has made to webmail.