SOLVED CSF Stuck on V 13.07

squadx

Active Member
Jan 26, 2012
37
0
56
cPanel Access Level
Website Owner
Unsure what is going here, there is 6 updated versions according the CSF changelog from the reported version on my server...

When I am in WHM and click the manual check, it is reporting this:
You are running the latest version of csf (v13.07). An Upgrade button will appear here if a new version becomes available

It does show this...(csget cron check) Failed to retrieve latest version from ConfigServer: https://download2.configserver.com/csf/version.txt - 501 Protocol scheme 'https' is not supported (LWP::Protocol::https not installed).

From ssh, I can't get a ping reply from download.configserver.com or downloads2.configserver.com

Do they (and why) block server IPs for any reason?
 

quietFinn

Well-Known Member
Feb 4, 2006
1,155
63
178
Finland
cPanel Access Level
Root Administrator
In CSF install.txt:

Code:
Perl Modules
============

While most should be installed on a standard perl installation the following
may need to be installed manually:

# On rpm based systems:
yum install perl-libwww-perl.noarch perl-LWP-Protocol-https.noarch perl-GDGraph
 

squadx

Active Member
Jan 26, 2012
37
0
56
cPanel Access Level
Website Owner
Yeah seems to more be my server is not connecting to the update/downloads server on CSF. Seeing as how ping doesn't report back a success, and trying manually to update with csf -u doesn't work either.

Why configserver would ban/block IP is a little strange to me
 

squadx

Active Member
Jan 26, 2012
37
0
56
cPanel Access Level
Website Owner
I made my own work around I guess. Just manually download from my browser the csf tgz file, uploaded it somewhere else, downloaded and installed v14.00 that way.
 

quietFinn

Well-Known Member
Feb 4, 2006
1,155
63
178
Finland
cPanel Access Level
Root Administrator

squadx

Active Member
Jan 26, 2012
37
0
56
cPanel Access Level
Website Owner
I don't think you get that error if the connection is blocked.
Probably more than one thing going on then, cause I ran those installs and the error didn't even go away, even after a reboot.
(ie: yum install perl-libwww-perl.noarch perl-LWP-Protocol-https.noarch perl-GDGraph)

When I click manual check it spins forever before I even got the latest version message. It provides a timeout in ssh with csf -u.
Either way the manual work around updated the version to v14.00. This is what reports in there now:

(csget cron check) Failed to retrieve latest version from ConfigServer: https://download2.configserver.com/csf/version.txt - 500 Can't connect to download2.configserver.com:443 (Connection timed out)

at least the: CCL Error: Unable to retrieve GeoLite2 Country database
msg in the lfd log file is gone now...which is why I wanted to get updated.
 

squadx

Active Member
Jan 26, 2012
37
0
56
cPanel Access Level
Website Owner
You might also want to let them know here: ConfigServer Community Forum - Index page in the event they're unaware there is a potential issue.
I did post something there, but that forum is quite inactive in terms of actual replies. They don't offer ticket support for the "free scripts", but the forum itself is usually kinda junk there.

Still don't know either way if CSF does/would ban a server IP, and I'm unsure why it even would to a basic process of downloading updates or just verifying the latest CSF version. Shouldn't be much else reason my server would ever be trying to contact theirs that would elicit a ban of any sorts.

Who knows, if you close threads here you can close this one.