The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CSF Warnings: Automatic upgrade to 11.30 build 11 from 11.28

Discussion in 'General Discussion' started by debug, May 13, 2011.

  1. debug

    debug Member

    Joined:
    Apr 19, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    CSF Firewall is displaying the following warning. Is it normal, doctor ?

    So, I received this message by email:
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,456
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:

    From WHM force an update, take two asprins and post back in the morning. ;)
     
  3. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    I recommend contacting the software vendor to inquire about an updated version of their application; it is likely they will need to revise their mechanism that checks for the installed and latest available cPanel version numbers.

    For further clarification, please refer to the following sections in the cPanel & WHM 11.30 Release Notes:
     
  4. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    The cPanel error_log will have more verbose information that can be relayed to the software developer; here is an example of the available detail that is logged when accessing the "Check Server Security" page in CSF version 5.21 installed alongside cPanel & WHM version 11.30.0.15:
    Code:
    # tail -fvn0 /usr/local/cpanel/logs/error_log
    ==> /usr/local/cpanel/logs/error_log <==
    [2011-05-13 21:29:48 -0500] invalid [addon_csf] Cpanel::Version::gettree is no longer meaningful. Try Cpanel::Update::Config::get_tier() at /usr/local/cpanel/Cpanel/Version.pm line 86
    	Cpanel::Version::gettree() called at /usr/local/cpanel/whostmgr/docroot/cgi/addon_csf.cgi line 48
    [2011-05-13 21:29:48 -0500] invalid [addon_csf] Cpanel::Version::getversiononly is deprecated. Try get_version_full. at /usr/local/cpanel/Cpanel/Version.pm line 54
    	Cpanel::Version::getversiononly() called at /etc/csf/servercheck.pm line 20
    	require /etc/csf/servercheck.pm called at /etc/csf/csfui.pl line 457
    	require /etc/csf/csfui.pl called at /usr/local/cpanel/whostmgr/docroot/cgi/addon_csf.cgi line 51
    [2011-05-13 21:29:48 -0500] invalid [addon_csf] Cpanel::Version::gettree is no longer meaningful. Try Cpanel::Update::Config::get_tier() at /usr/local/cpanel/Cpanel/Version.pm line 86
    	Cpanel::Version::gettree() called at /etc/csf/servercheck.pm line 23
    	require /etc/csf/servercheck.pm called at /etc/csf/csfui.pl line 457
    	require /etc/csf/csfui.pl called at /usr/local/cpanel/whostmgr/docroot/cgi/addon_csf.cgi line 51
    [2011-05-13 21:29:49 -0500] invalid [addon_csf] Cpanel::Version::getversion is deprecated. Try get_version_full. at /usr/local/cpanel/Cpanel/Version.pm line 44
    	Cpanel::Version::getversion() called at /etc/csf/servercheck.pm line 592
    	main::whmcheck() called at /etc/csf/servercheck.pm line 63
    	require /etc/csf/servercheck.pm called at /etc/csf/csfui.pl line 457
    	require /etc/csf/csfui.pl called at /usr/local/cpanel/whostmgr/docroot/cgi/addon_csf.cgi line 51
     
  5. Hispalab

    Hispalab Well-Known Member

    Joined:
    Apr 17, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Madrid -Spain
    I recomend not upgrade to new 11.30 because I detect some problems not resolved.
    1.- mailman permisions
    2.- horde permisions
    This can not be resolved by now with scripts included
     
  6. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    983
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    Can you please elaborate on this? Where exactly did you see these permissions problem?
     
  7. Hispalab

    Hispalab Well-Known Member

    Joined:
    Apr 17, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Madrid -Spain
    mailman old error "500" when try access to management list.
    "Warning: Private archive directory is other-executable (o+x).
    This could allow other users on your system to read private archives.
    If you're on a shared multiuser system, you should consult the
    installation manual on how to fix this.
    Im sorry i can not remember exact error of Horde. Horde show how many msg have in mailbox.. but give error of access to mailbox and show white page, not mail messages.

    If your server is a production server I m recomending not upgrade by now.
    If you need downgrade run /usr/local/cpanel/scripts/downgrade_cpanel and all back to normal working well.
     
  8. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    983
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    Where exactly do you see this error? I just logged into mailman on one of our "WHM 11.30.0 (build 16)" servers and didn't see any errors.

    really? Again, I don't see such behavior and could access all messages inside Horde, even in different folders
     
  9. Hispalab

    Hispalab Well-Known Member

    Joined:
    Apr 17, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Madrid -Spain
    congratulations i test it on CENTOS 5.6 i686 with this problem. If you dont have... congratulations. :)


    from log
    [20110516.102622] - Processing command `./check_perms -f --noarchives`
    [20110516.102624] [23702] Warning: Private archive directory is other-executable (o+x).
    [20110516.102624] [23702] This could allow other users on your system to read private archives.
    [20110516.102624] [23702] If you're on a shared multiuser system, you should consult the
    [20110516.102624] [23702] installation manual on how to fix this.
     
    #9 Hispalab, May 16, 2011
    Last edited: May 16, 2011
  10. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    983
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    Maybe it's a i686 problem then, since we only use X86:

    Code:
    root@mercury:[~]$ uname -a
    Linux mercury.x.x.x 2.6.18-8.1.15.el5xen #1 SMP Mon Oct 22 09:01:12 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux
    root@mercury:[~]$ cat /etc/redhat-release
    CentOS release 5.6 (Final)
    
    
    In which log file did you get those errors?

    I just check /var/log/messages AND the whole /var/log/ folder and couldn't find it:

    Code:
    root@mercury:[~]$ grep check_perms /var/log/messages
    root@mercury:[~]$ grep check_perms /var/log/*
    root@mercury:[~]$
    
    
     
  11. debug

    debug Member

    Joined:
    Apr 19, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Also I lost a lot of saved emails since upgrade to 11.30.

    + this issue:
    cpanellogd failed @ Sun May 15 02:06:35 2011. A restart was attempted automagically.
    Service Check Method: [check command]
    Number of Restart Attempts: 1
    Cmd Service Check Raw Output: cpanellogd is not running



    It is possible to downgrade to 11.29.1.5 without problems ?

    CENTOS 4.9 i686 virtuozzo on server
     
    #11 debug, May 16, 2011
    Last edited: May 16, 2011
  12. Hispalab

    Hispalab Well-Known Member

    Joined:
    Apr 17, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Madrid -Spain
    yes you can downgrade with
    /usr/local/cpanel/scripts/downgrade_cpanel
     
  13. debug

    debug Member

    Joined:
    Apr 19, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    My hosting provider said there is no way to downgrade from one version of cPanel to an older version. They would have to restore my VPS entirely from backup to do so.
     
  14. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,736
    Likes Received:
    661
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Downgrading from cPanel version 11.30 to version 11.28 is currently possible using the steps found at:

    Downgrading to version 11.28

    Please note, once version 11.30 enters the stable tier, version 11.28 will no longer be available for download, making downgrading impossible.

    Thank you.
     
  15. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    983
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    What version of CSF are you running?

    One of of our servers I see that WHM is on "WHM 11.30.0 (build 16)" and CSF on "csf: v5.21" yet I don't see that error message
     
Loading...

Share This Page