The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CSR generation troubles

Discussion in 'General Discussion' started by mpope2, Jul 3, 2002.

  1. mpope2

    mpope2 Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    I am having trouble generating a CSR for a client using WHM. I input everything properly and hit submit, it generates the private key fine, but where the CSR should be, it is just an empty box. Also, in the emails that it send, the private key shows up fine, but the CSR does not show up at all.

    Please let me know what I can do to correct this issue. I would rather not generate the CSR manually.

    Thanks!
     
  2. mpope2

    mpope2 Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Anyone have any suggestions on this? My client really needs a CSR generated asap.

    Thanks!
     
  3. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Hmmmmmmmmmmmm.....

    That is one of the more sporadically buggy things in the WHM, from time to time. I would log in as root and do a locate for the CSR on the filesystem.... (locate www.DOMAIN.com.csr)
    Should be able to find it.

    Or just start the process over from the shell and use:
    /scripts/gencrt

    (/scripts/installssl to install the cert once you have it, or use WHManager if you think it healed itself)

    ;)
     
  4. mpope2

    mpope2 Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    I got it to work. I guess it doesn't like it if you put the https:// in there, although I could swear I've done it like that 4-5 other times! :p

    Thanks!
     
Loading...

Share This Page