Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

curl error on OWASP ModSecurity Core Rule Set V3.0 installation

Discussion in 'Security' started by kamranonline, Dec 10, 2018.

  1. kamranonline

    kamranonline Member

    Joined:
    Sep 16, 2012
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Newtowncenter
    cPanel Access Level:
    Root Administrator
    Hi,

    I tried to install OWASP but its failed.
    I Also check /etc/resolve.conf and tried to use curl http://httpupdate.cpanel.net/modsecurity-rules/meta_OWASP3.yaml and the response was correct when I used curl or wget but its not possbile to install it via WHM.

    Error: The system experienced the following error when it attempted to install the “OWASP ModSecurity Core Rule Set V3.0” vendor: API failure: The system could not download the file “http://httpupdate.cpanel.net/modsecurity-rules/meta_OWASP3.yaml”: curl: (28) Resolving timed out after 1544150479011 milliseconds
     
  2. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    5,815
    Likes Received:
    443
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hello @kamranonline

    To confirm, you checked curl via the server? Can you show us the output of the curl request you performed from the server?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. kamranonline

    kamranonline Member

    Joined:
    Sep 16, 2012
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Newtowncenter
    cPanel Access Level:
    Root Administrator
    Code:
    curl http://httpupdate.cpanel.net/modsecurity-rules/meta_OWASP3.yaml
    ---
    2.9.0:
      MD5: bc15925c08a4bdcb48bf4c36f2e246a2
      SHA512: 55455e183d9b7680952d04bbbaf0e6ca4119b5ddfe760612dc653cb89353d97ee2c69b2a3f33a969d268bb4bc11fdcbb40b997fe72b6aca1591036520687fbb9
      distribution: OWASP3_1491589290
      url: http://httpupdate.cpanel.net/modsecurity-rules/OWASP3_1491589290.zip
    2.9.2:
      MD5: 2697e62531ab49f3907d10049bfc18a0
      SHA512: cee19f6abb78e52f7ea51a4cfbc3783fa8e60d88f5ae8b959026eeafff4d0d49f0538daf9302c61df26209f28a1eebc0b0e2ddd02036411ab8dae3c2d464f5ef
      distribution: OWASP3_1501094486
      url: http://httpupdate.cpanel.net/modsecurity-rules/OWASP3_1501094486.zip
    attributes:
      description: 'SpiderLabs OWASP curated ModSecurity rule set'
      name: 'OWASP ModSecurity Core Rule Set V3.0'
      report_url: https://www.modsecurity.org/rule_issue_report/cPanel/report/new
      vendor_url: https://go.cpanel.net/modsecurityowasp
    
     
    #3 kamranonline, Dec 19, 2018
    Last edited by a moderator: Dec 19, 2018
  4. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    5,815
    Likes Received:
    443
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @kamranonline


    Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice