The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CURL not resolving domains

Discussion in 'General Discussion' started by kmpanilla, Dec 1, 2007.

  1. kmpanilla

    kmpanilla Member

    Joined:
    Oct 24, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Upgraded to -RELEASE last night, and upgraded to apache2.2/php5. Now, CURL is not able to resolve names.

    Even a quick test of:
    $ch = curl_init("www.google.com");

    if (!curl_exec($ch)) {
    print curl_error($ch);
    }

    shows this:
    Couldn't resolve host 'www.google.com'

    However, if I use an IP it works just fine.


    /opt/curlssl/bin/curl --version
    curl 7.16.0 (i386-unknown-freebsd6.2) libcurl/7.16.0 OpenSSL/0.9.8d zlib/1.2.3 libidn/1.2

    WHM 11.11.0 cPanel 11.15.0-R18264
    FREEBSD 6.2-RELEASE-p5 i386 on standard - WHM X v3.1.0

    Anybody having similar issues? Any solutions?
     
  2. gdns

    gdns Active Member

    Joined:
    Feb 12, 2007
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    yes

    update to freebsd 6.3 prerelease

    (search for my login, you will see i have had a simmelary issue)
     
  3. kmpanilla

    kmpanilla Member

    Joined:
    Oct 24, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    upgraded to 6.3-RC1 and it works as expected. thanks for the suggestion.
     
  4. AnilR

    AnilR Active Member

    Joined:
    Nov 24, 2007
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    Have you enable curl in the php.ini on your server. check with this command

    # php -v
     
Loading...

Share This Page