cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Hello :)

cURL itself is installed through EasyApache under the "Exhaustive Options List" for PHP. You can find it located at:

Code:
/usr/bin/curl
You would need to manually compile libcurl with the AsynchDNS variable enabled.

Thank you.
 

MojoCreations

Active Member
Feb 14, 2012
31
0
56
cPanel Access Level
Root Administrator
Thanks for the response Michael. I was trying to find out how to compile it. This is what i have done so far, will this work?

wget http://c-ares.haxx.se/download/c-ares-1.10.0.tar.gz
tar xvzf c-ares-1.10.0.tar.gz
cd c-ares-1.10.0/
./configure
make
make install

wget http://curl.haxx.se/download/curl-7.32.0.tar.bz2
tar jxvf ./curl-7.32.0.tar.bz2
rm -f ./curl-7.32.0.tar.bz2
cd /usr/local/src/curl-7.32.0
./configure --enable-ares --enable-threaded-resolver --enable-http --enable-ftp --enable-proxy --enable-tftp --enable-ntlm --enable-static --with-ssl=/usr/local/ssl --enable-ipv6 --enable-shared --disable-ldap --with-libidn --disable-rtsp --without-zlib
make
make install

----Update----

I actually tried this above and it didn't seem to work, everything compiled and i restarted the server but AsynchDNS still isn't enabled.

I also tried installing c-ares first, then compiling curl with the --enable-ares=/usr/local/ variable but it doesn't seem to have worked either.

10.04.2013-12.41.png
 
Last edited:

MojoCreations

Active Member
Feb 14, 2012
31
0
56
cPanel Access Level
Root Administrator
I ran the install again after installing c-ares, then i ran curl-config and it shows that the feature AsynchDNS is installed but its not showing up in my phpinfo file

root [/usr/local/src/curl-7.32.0]# curl-config --features --protocols
SSL
IPv6
libz
AsynchDNS
IDN
NTLM
NTLM_WB
DICT
FILE
FTP
FTPS
GOPHER
HTTP
HTTPS
IMAP
IMAPS
POP3
POP3S
SMTP
SMTPS
TELNET
TFTP


****Update****
I ran everything as needed and ran curl --version which shows the correct curl version that i just installed but thats not what shows up in my phpinfo page, it still shows the old version and no AsynchDNS.

[email protected] [/usr/local/src/curl-7.32.0]# curl --version
curl 7.32.0 (x86_64-unknown-linux-gnu) libcurl/7.32.0 OpenSSL/1.0.0 zlib/1.2.3 c-ares/1.10.0 libidn/1.18
Protocols: dict file ftp ftps gopher http https imap imaps pop3 pop3s smtp smtps telnet tftp
Features: AsynchDNS GSS-Negotiate IDN IPv6 Largefile NTLM NTLM_WB SSL libz
 
Last edited:

MojoCreations

Active Member
Feb 14, 2012
31
0
56
cPanel Access Level
Root Administrator
Compiling Curl with AsynchDNS in Apache

I haven't been able to get any type of response to my previous post and think that maybe i posted to the wrong forum. This is what i have done in hopes to get my curl version with asynchdns to compile with apache because if i run curl version through ssh it shows the newest version of curl with asynchdns but if i run a phpinfo.php it shows an older curl version without asynchdns. Does anyone have any idea how I can get this compiled when i run easyapache?

wget http://c-ares.haxx.se/download/c-ares-1.10.0.tar.gz
tar xvzf c-ares-1.10.0.tar.gz
cd c-ares-1.10.0/
./configure
make
make install

wget http://curl.haxx.se/download/curl-7.32.0.tar.bz2
tar jxvf ./curl-7.32.0.tar.bz2
rm -f ./curl-7.32.0.tar.bz2
cd /usr/local/src/curl-7.32.0
./configure --enable-ares --enable-threaded-resolver --enable-http --enable-ftp --enable-proxy --enable-tftp --enable-ntlm --enable-static --with-ssl=/usr/local/ssl --enable-ipv6 --enable-shared --disable-ldap --with-libidn --disable-rtsp --without-zlib
make
make install

I actually tried this above and it didn't seem to work, everything compiled and i restarted the server but AsynchDNS still isn't enabled via phpinfo.php

Next

I ran the install again after installing c-ares, then i ran curl-config and it shows that the feature AsynchDNS is installed but its not showing up in my phpinfo file

root [/usr/local/src/curl-7.32.0]# curl-config --features --protocols
SSL
IPv6
libz
AsynchDNS
IDN
NTLM
NTLM_WB
DICT
FILE
FTP
FTPS
GOPHER
HTTP
HTTPS
IMAP
IMAPS
POP3
POP3S
SMTP
SMTPS
TELNET
TFTP


I ran everything as needed and ran curl --version which shows the correct curl version that i just installed but thats not what shows up in my phpinfo page, it still shows the old version and no AsynchDNS.

[email protected] [/usr/local/src/curl-7.32.0]# curl --version
curl 7.32.0 (x86_64-unknown-linux-gnu) libcurl/7.32.0 OpenSSL/1.0.0 zlib/1.2.3 c-ares/1.10.0 libidn/1.18
Protocols: dict file ftp ftps gopher http https imap imaps pop3 pop3s smtp smtps telnet tftp
Features: AsynchDNS GSS-Negotiate IDN IPv6 Largefile NTLM NTLM_WB SSL libz

So it looks like curl is installed (new version) with asynchdns but its not compiling in easyapache.
 

MojoCreations

Active Member
Feb 14, 2012
31
0
56
cPanel Access Level
Root Administrator
This seemed to be an easy answer even though no one was able to respond. Once you have your working version of Curl installed and c-ares you can then add these function calls to

/var/cpanel/easy/apache/rawopts/all_php5

You need to make an all_php5 file and enter the below function calls to that file

--with-gssapi
--with-curl=/usr/local/src/curl-7.32.0
--enable-ares=/usr/local/src/c-ares-1.10.0

Save your file then recompile easyapache and BAM, you should have the new Curl and AsynchDNS working.