The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CURRENT mangling cpanel's php.ini?

Discussion in 'General Discussion' started by MediaServe, Feb 28, 2008.

  1. MediaServe

    MediaServe Well-Known Member
    PartnerNOC

    Joined:
    Apr 9, 2004
    Messages:
    126
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nashville, TN USA
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Yesterday I started getting complaints that Fantastico wasn't working. I found that indeed it was no working on ANY of our cpanel servers.

    I eventually figured out that /usr/local/cpanel/3rdparty/etc/php.ini had been messed up on all servers.

    This also caused cpanel function failures such as the inability to create a mailing list.

    After replacing the mangled php.ini with a good one, everything was working again.

    This morning, they're all corrupted again, in the same manner. Something about the overnight cpanel update appears to be causing this.

    We're running CURRENT:

    WHM 11.15.0 cPanel 11.18.1-C21312
    REDHAT Enterprise 4 i686 on standard - WHM X v3.1.0

    Can anyone else check and verify this problem? For us, if you pico -w /usr/local/cpanel/3rdparty/etc/php.ini, and start paging down, you'll find entire sections of the php.ini where the comments are in place to the right, but no directives are to be found on the left.
     
  2. swampy

    swampy Well-Known Member

    Joined:
    Jan 30, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    0
    I too am having the same problem but i cannot find a backup to restore do you know where the backup is stored so i can restore it

    Cp update keeps killing 3rdparty php.ini i have even tried a forced update but nothing works

    WHM 11.15.0 cPanel 11.18.1-C21312
    CENTOS Enterprise 4.6 i686 on standard - WHM X v3.1.0

    Thanks
    Mark
     
  3. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    This issue has been reported to us and is currently under investigation.
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The problem was the 3rdparty/etc/php.ini on the update mirrors and is being resolve right now.
     
  5. swampy

    swampy Well-Known Member

    Joined:
    Jan 30, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    0
    Kenneth has this issue been resolved yet or is it still being sorted

    Mark
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Yes, it is resolved.
     
  7. stphosting

    stphosting Well-Known Member

    Joined:
    Oct 17, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    no its not resolved i have the same problem and now even the fantastico whm works
     
Loading...

Share This Page