The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Custom Apache configs are "ignored" when included via Post VirtualHost Includes

Discussion in 'EasyApache' started by danaus, Sep 19, 2010.

  1. danaus

    danaus Registered

    Joined:
    Sep 19, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    We have a CMS running on our server, and it automatically generates its own VirutalHost records for the domains/sub-domains of the sites which run within it.

    I've added this line to the Post VirtualHost Includes in the Apache Includes Editor:
    Include "/home/username/cms/data/conf/*.conf"

    apachectl -S tells me that apache can see and process the .conf files in /home/username/cms/data/conf/ without any issues, but when I go to a domain/sub-domain which is configured via one of these config files I get the "Default Website Page" message in the browser (/usr/local/apache/htdocs ?).

    I'm new to working with cPanel, so I may have missed a configuration option, or perhaps the file permissions on the .conf files are incorrect, or something insignificant like that.

    Is anyone able to provide some advice which could help me solve the problem?

    Secondary question: is this sort of behaviour actually possible with cPanel?
     
Loading...

Share This Page