The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Custom error page not used

Discussion in 'General Discussion' started by masnet, Sep 21, 2007.

  1. masnet

    masnet Registered

    Joined:
    Sep 21, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    A custom error page, called 404.shtml, placed 1 day ago, in /public_html/, is not being used. What could be the reason? How to remedy this?
    Thanks!
     
  2. masnet

    masnet Registered

    Joined:
    Sep 21, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Solution to missing custom 404 page

    Found the solution in an old thread.
    Just in case someone with the same problem stumbles on this question:

    What the cPanel documentation does not tell is that one has to make an entry in the corresponding
    .htaccess file (generally the one in the public_html folder).

    The entry in the .htaccess file should look like:
    ErrorDocument CODENUMBER ERRORFILE

    E.g:
    ErrorDocument 404 /custom-404.shtml

    --
    One can also make specific error codes for subdomains by modifying the .htaccess file in the subdomain's directory and placing the subdomain-specific error page there.

    The full info is available on:
    http://support.hostgator.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=312

    Enjoy

    M
     
Loading...

Share This Page